Jump to content

Stacks Docklet 2.0


Recommended Posts

This 2.0 version is Amazing !

But when the dock is on the top of the screen there is a problem, you know it ? the stack show icons on the top of the dock ...

Only with the fan mode!

thank you.

Edited by Tardio
Link to post
  • Replies 525
  • Created
  • Last Reply

Top Posters In This Topic

Anyone able to get this to work on Vista Ultimate x64? I have Rocketdock and have installed everything to their proper directories and it keeps crashing the program. If I delete the StackLib.dll it loads up fine but obviously the docklet won't work.

I even tried RKLauncher and still nothing. :(

Any ideas? Thanks!

Link to post

The UAC issue I mentioned above also shows - apparently with the exact same behavior - with Access 2007 files which are NOT set to run as Administrator. I have several .mdb files with shortcuts in a stack and each time I click on one, Access correctly runs and loads the file, then after a small delay (a couple of seconds) Rocketdock crashes. I have checked, running only Access 2007 (the application) is fine, as is running other shortcuts to files, .PDF for example. If I change the shortcut to run "<path>\msaccess.exe" file.mdb instead of just file.mdb everything is fine (which is also fine as a workaround until you fix it ;) ). Of course this also worked in 1.0.

Link to post

Great docklet.

My wish list:

1. In fan mode, ability to choose to sort by descending or ascending order

2. Put the "StackLib.dll" in the stackdocklet folder

3. Change the stack icon size, but I guess I will have to wait for the tweak tool

4. The ability to "follow dock", this ability was there in v1 but I didn't use it because it crashed RocketDock/ObjecDock when I activated more than 2 stacks

Anomaly report:

1. When you have 2 stacks, click on one stack and let it expand, then immediately click the other stack. In RocketDock, this will result in the 2nd stack fanning out using the small icon size.

Again, great work!

Link to post
Anyone able to get this to work on Vista Ultimate x64? I have Rocketdock and have installed everything to their proper directories and it keeps crashing the program. If I delete the StackLib.dll it loads up fine but obviously the docklet won't work.

I even tried RKLauncher and still nothing. :(

Any ideas? Thanks!

Try Stacks Docklet v1.0

It is more stable and besides, this is just a pre-beta, it'll get a lot better with time.

Stacks Docklet v1.0 works fine and great :) but was hoping I could try/test out v2.0 :( and of course wondering any anyone else was experiencing the same problems as me and know of a fix.

Link to post
Stacks Docklet v1.0 works fine and great :) but was hoping I could try/test out v2.0 :( and of course wondering any anyone else was experiencing the same problems as me and know of a fix.

I am using Vista Ultimate x64 and both v1 and v2 are fine. For v2, I put the StackLib.dll in the rocketdock main folder, and delete the one from the docklet folder.

I also deleted v1 form the docklet folder, and removed v1 docklet from the dock.

Edited by pkuok
Link to post
I am using Vista Ultimate x64 and both v1 and v2 are fine. For v2, I put the StackLib.dll in the rocketdock main folder, and delete the one from the docklet folder.

I also deleted v1 form the docklet folder, and removed v1 docklet from the dock.

Just tried what you suggested again in case I did it wrong or messed up previously... Still crashes :(

It has something to do with the StackLib.dll when I delete or move it to another directory other then the main (for testing). The dock won't crash but obviously I can't use the program. Out of ideas :angry:

Link to post
Just tried what you suggested again in case I did it wrong or messed up previously... Still crashes :(

It has something to do with the StackLib.dll when I delete or move it to another directory other then the main (for testing). The dock won't crash but obviously I can't use the program. Out of ideas :angry:

Could be.

When I first fired up RocketDock after the switch from V1 to V2, I lost all my V1 stacks. So I deleted all the V1 stacks from the docks. Then was playing around with creating new stacks, until I found that if my stack has a shortcut to a networked server, clicking on that icon would also crash my dock. After several tries the problem went away by itself.

I found that RocketDock is quite particular about networked shortcuts. ObjectDock is more tolerable in that regard. But then I don't use ObjectDock that often.

Link to post
Could be.

When I first fired up RocketDock after the switch from V1 to V2, I lost all my V1 stacks. So I deleted all the V1 stacks from the docks. Then was playing around with creating new stacks, until I found that if my stack has a shortcut to a networked server, clicking on that icon would also crash my dock. After several tries the problem went away by itself.

I found that RocketDock is quite particular about networked shortcuts. ObjectDock is more tolerable in that regard. But then I don't use ObjectDock that often.

ya I don't know what else is wrong or what to do to fix it. Guess I'll just have to wait for the beta/final version. Hopefully someone who has/had the same problem as me posts a fix for it though in the mean time :). Thanks though!

Link to post

Doesn't work for me either, Vista Ultimate SP1 32-Bit. Any time I try to add a Stack Docklet 2.0, RocketDock 1.3.5 crashes. When I try to start it back up, it crashes again. When I try to start it up a second time, it tells me it had trouble loading my icons last time it was run and asks whether I want to load the default icons. If I click No, it crashes again. If I click Yes, it starts up fine. Until, of course, I try to add a Stack Docklet 2.0 again, at which point the crashing cycle repeats. I also tried it on ObjectDock 1.9 with similar results. Any time I click New "Stack Docklet 2.0" Docklet, the program crashes.

I tried everything I could think of with RocketDock. Compatibility Mode, reinstalling the program (including manually deleting all remnants from the Program Files folder after uninstalling it), nothing works. It can't be UAC because UAC is disabled on this account. It also cannot be my administrative privileges (though I tried Run as Administrator for giggles), because I am using the actual Administrator account.

This is happening with both the February 20th and the March 5th builds. Guess I'll have to go back to Stacks Docklet 1.0 for the time being (No, I didn't try running 2.0 without removing 1.0, and my ObjectDock never even had 1.0 installed, actually).

:(

Link to post

Weird... I'm running it under Vista Ultimate SP1 32 bit and Rocketdock 1.3.5 myself and it runs OK. It even worked with 1.0 installed, though a few error dialogs sometimes popped up. I also have UAC enabled without problems, apart, it seems, shortcuts set to run as Administrator that crash the dock. Just to test, do not install it under program files, make some "tools" folder in the root of the drive and install inside it. Both Rocketdock and the Stacks 2.0 docklet, that is.

Link to post

This Version is great !

It would be better if we could choose the icon's size, and to choose a bold or regular font (and the font !)...

And I have a little problem : I 've got some icons (.ico) which are in a very high resolution ... and the docklet doesn't display them right ... It only display a part of them.

How can I fix this ?

Thanks

Link to post
Matonga, sorry to be pesty, but any idea when we are goign to get a stand alone version of this? I'm DYING to use it! :)

A standalone version which is fairly stable for vers. 1.0 has been made on Chrisn'softs website. Matonga is currently talking to the developer of the standalone vers and are in cahoots in making the 2.0 vers.

Link to post

Today I tried to get from stackdocklet 1 to stackdocklet2. I now have the problem that in my shell32.dll I use an icon (No.4, standart folder) in which the biggest size is an empty icon to get the pictures preview without background (the big folder).

Now the stacksdocklet2 uses this biggest icons, so that now the folders are not shown in stack and also not in the stack preview.

Short: My icon4 is empty, the stack shows no folders.

OK, I understand this is beta, just wanted to let you know.

Great work, thanks.

Link to post

I put "StackLib.dll" in the "...\ObjectDock" directory and the "StackDocklet2.0" folder in the "...\ObjectDock\Docklets" directory. When I click to add the Stacks Docklet 2.0 to ObjectDock (1.90 build 536) it immediately crashes. I'm using Vista.

Help!

Link to post
Today I tried to get from stackdocklet 1 to stackdocklet2. I now have the problem that in my shell32.dll I use an icon (No.4, standart folder) in which the biggest size is an empty icon to get the pictures preview without background (the big folder).

Now the stacksdocklet2 uses this biggest icons, so that now the folders are not shown in stack and also not in the stack preview.

Short: My icon4 is empty, the stack shows no folders.

OK, I understand this is beta, just wanted to let you know.

Great work, thanks.

Try adding an even bigger icon into shell32.dll's icon 4 and see what happens... or... change icon within shell icons registry key:

regedit.exe > ... oops, can't find Shell Icons in my laptop... ok, google it, it's the way IconTweaker and other apps replace the folder icon without touching the shell32.dll file.

Link to post

shell32.dll only works up to 128x128. I cannot find the reg key with google. Not that important, just if you find it somewhere, can you post it?

But icon tweaker looks great. What theme do you use?

EDIT: Wow, this is one great tool. Don´t know how I lived without it untill now.

Edited by Björn
Link to post

Matonga, it seems like you're ignoring everyone who reports a crashing problem similar to the ones below:

I am also experiencing problems of stacks docklet 2 crashing OD. I'm currently running OD+ 1.9 build 535u. When I try to add the docklet to the dock it automatically crashes. I have been running version 1.0 of stacks, do I have to completely remove it and the stack icons from my dock to use this version of stacks. Any help would be greatly appreciated. The new version looks great from what I've seen from others, keep up the good work.

I've completely removed the stacks v1 from the object dock folder and the dock still crashes. Along with that I've also tried a fresh install of objectdock and rocketdock and they also crash. I'm not really sure what the problem is I'm like 99.999% sure I'm putting all the files in the right place. Any help would be appreciated.
Weird. I extracted the StackLib.dll into the OD directory and StackDocklet2.0 folder into the Docklets folder. Launched OD for the first time, added a stack docklet, all worked well. Rebooted the PC and every time I try to run OD it crashes while the StackLib.dll is in the main directory. I deleted the StackLib.dll, now OD works fine but the stacks docklet doesn't. I tried reinstalling and it does the same thing every time.
Anyone able to get this to work on Vista Ultimate x64? I have Rocketdock and have installed everything to their proper directories and it keeps crashing the program. If I delete the StackLib.dll it loads up fine but obviously the docklet won't work.

I even tried RKLauncher and still nothing. :(

Any ideas? Thanks!

Just tried what you suggested again in case I did it wrong or messed up previously... Still crashes :(

It has something to do with the StackLib.dll when I delete or move it to another directory other then the main (for testing). The dock won't crash but obviously I can't use the program. Out of ideas :angry:

Doesn't work for me either, Vista Ultimate SP1 32-Bit. Any time I try to add a Stack Docklet 2.0, RocketDock 1.3.5 crashes. When I try to start it back up, it crashes again. When I try to start it up a second time, it tells me it had trouble loading my icons last time it was run and asks whether I want to load the default icons. If I click No, it crashes again. If I click Yes, it starts up fine. Until, of course, I try to add a Stack Docklet 2.0 again, at which point the crashing cycle repeats. I also tried it on ObjectDock 1.9 with similar results. Any time I click New "Stack Docklet 2.0" Docklet, the program crashes.

I tried everything I could think of with RocketDock. Compatibility Mode, reinstalling the program (including manually deleting all remnants from the Program Files folder after uninstalling it), nothing works. It can't be UAC because UAC is disabled on this account. It also cannot be my administrative privileges (though I tried Run as Administrator for giggles), because I am using the actual Administrator account.

This is happening with both the February 20th and the March 5th builds. Guess I'll have to go back to Stacks Docklet 1.0 for the time being (No, I didn't try running 2.0 without removing 1.0, and my ObjectDock never even had 1.0 installed, actually).

:(

I put "StackLib.dll" in the "...\ObjectDock" directory and the "StackDocklet2.0" folder in the "...\ObjectDock\Docklets" directory. When I click to add the Stacks Docklet 2.0 to ObjectDock (1.90 build 536) it immediately crashes. I'm using Vista.

Help!

Could we get any sort of feedback on why these crashes occur?

Edited by FishStik
Link to post
Simple answer. Do not use Vista.

It´s the same crap like Windows Me. Half ready and not supported.

Go back to XP or wait for Windows 7.

You're right... Windows 9X architecture is completely the same as Windows NT architecture.

Honestly, what a stupid comment.

Link to post

FishStik - show a little respect, dude...

Matonga is one of the most prolific coders at aqua-soft, and despite his seemingly boundless desire to create community apps, he also has a real life to live (just something I assume...) ;)

I perfectly understand you can't wait to see the RC, but you'll just have to sit quietly and bit your fingernails like the rest of us...

Link to post

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...