Jump to content

Bug Report Center


siik

Recommended Posts

@ bobah:

- Testing current version of XWD and it doesnt take focus correclty, while any window is active (not maximized), animation works when mouse over, but it stays behind the window. If it is maximized and move mouse to the bottom of screen it gets focus, but it doesnt give focus back, XWD stays on top. (maybe this issue is already known, sorry :) )

@ atreiu:

-Feature request on xCal. Could you please add the option to change the font format?

-Feature request on xMail. Maybe add an option to play a sound when having new mail.?

By Panta: moved, as bugs must be reported at this thread and not the main one. Please, read the new guidelines.

Link to post
  • Replies 350
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Posted Images

I heard many people complain about the magnification effect and the memory usage. Is it fixed now?

I can't understand... so when you use icons, there refletions, stacks, window's reflections, big skins files... where do I must save all of them in your opinion ? So of course I can use only 1 or 2 MB of memory and then when some of icons will have to repaint I'll do next step:

1. unpack the skin

2. load skin into memory

3. paint icon, and get memory for all effects

4. unload memory

and it takes time like preview of skins in parameters, and I think it taks more time...

So do you want it ? of course you can also ask why rocket dock for example doesn't use so a lot of memory.. of cours I can answer you, has it icon's reflection or icon's shadow or window's relfection or so many options ? So you should think about it.... or when you use explorer :) did you see how much memory it used ?

About magnification, now it's perfect.

Link to post
XWD follows both your settings at its 'Preferences' window and the settings of the skin you're using (just open it with XWD Skin Editor and you'll see them), so no, it won't adjust itself due to resolution changes, at least up to now. It's not a bug, it's a characteristic of its inception by bobah.

Not sure if I was clear about my post. My issue has nothing to do with skin or preferences. Lets say my screen resolution is 1600X1200 and xwd is positioned to the bottom center of the screen. Now, if I change my resolution to 1024X768 then XWD doesnt not reposition itself to the new bottom center. It stays where it was originally outside the visible area of the screen.

same applies on reverse. Going from 1024x768 to 1600x1200, the dock stays floating somewhere in the middle of the screen rather than the center bottom.

hope that is clear. I know rocketdock would reposition when screen resolution changed. Currently I need to exit and restart xwd to have it reposition to the new dimensions

Link to post
I can't understand... so when you use icons, there refletions, stacks, window's reflections, big skins files... where do I must save all of them in your opinion ? So of course I can use only 1 or 2 MB of memory and then when some of icons will have to repaint I'll do next step:

1. unpack the skin

2. load skin into memory

3. paint icon, and get memory for all effects

4. unload memory

and it takes time like preview of skins in parameters, and I think it taks more time...

So do you want it ? of course you can also ask why rocket dock for example doesn't use so a lot of memory.. of cours I can answer you, has it icon's reflection or icon's shadow or window's relfection or so many options ? So you should think about it.... or when you use explorer :) did you see how much memory it used ?

About magnification, now it's perfect.

Nah, I want a Dock, reflecting everything, in realtime, even my Keyboard and my hands. Besides that, it should check my emails, and answer them, host a calendar application and must have visual effects like ILM's "WALL-E". But it should certainly not use more than 1MB RAM, because I only have .... 2000 ... of them... :P

Seriously guys: animations was under constant development all the time. And i predict it will be ;) And a Memory Footprint under 30MB is absolutely except-able in these days. Especially if you want smooth effect, there is some caching to memory necessary. My XWD is using ~15MB, which is great. ObjectDock is using ~7MB without any docklet for me, and has no including Stacks, reflections, (and soon: gallery).

Link to post
Not sure if I was clear about my post. My issue has nothing to do with skin or preferences. Lets say my screen resolution is 1600X1200 and xwd is positioned to the bottom center of the screen. Now, if I change my resolution to 1024X768 then XWD doesnt not reposition itself to the new bottom center. It stays where it was originally outside the visible area of the screen.

same applies on reverse. Going from 1024x768 to 1600x1200, the dock stays floating somewhere in the middle of the screen rather than the center bottom.

hope that is clear. I know rocketdock would reposition when screen resolution changed. Currently I need to exit and restart xwd to have it reposition to the new dimensions

@Bobah:

WM_DISPLAYCHANGE

Link to post

@Panta, I just find that this thread is best to ask question about bugs. I'm not trying to annoy anyone.

@Bobah, thanks for your answer, I just thought that the memory usage is a bug, but now I understand why. Thanks ;)

and one more question, if I turn off all those effects, would it takes as low ram as other dock programs?

Link to post
@Panta, I just find that this thread is best to ask question about bugs. I'm not trying to annoy anyone.

@Bobah, thanks for your answer, I just thought that the memory usage is a bug, but now I understand why. Thanks ;)

and one more question, if I turn off all those effects, would it takes as low ram as other dock programs?

I tried it, and it went down like 1 mb if I remember :slant:

Link to post

Hey guys, I have a problem with xwindowsdock not starting, this started after I added the Xmail, Xcal, and screenshot docklets. Now, when I try to open Xwindows dock all I get is the error message in the screenshot. I have already tried restarting my computer and removing the docklets from the XwindowsdockDocklets Directory to no avail, does any one have a solution?

post-89042-1232068812_thumb.png

Link to post
Hey guys, I have a problem with xwindowsdock not starting, this started after I added the Xmail, Xcal, and screenshot docklets. Now, when I try to open Xwindows dock all I get is the error message in the screenshot. I have already tried restarting my computer and removing the docklets from the XwindowsdockDocklets Directory to no avail, does any one have a solution?

Have you tried to reinstall XWindowsDock? I mean: delete the whole XWindowsDock Directory, than start over by reinstalling it. That usually helps with this kind of problems.

Link to post
i really didn't want to do that, but if it may fix it i'll try it

back everything up first! :o

Edit: XWD crashes from time to time when installing new docklets or modifying things. Be sure to back up your configuration files every time you find a configuration you like, or before you do something new. I personally have only had to replace everything once, and I've been following XWD since it's page count was in the single digits :P

Link to post
i really didn't want to do that, but if it may fix it i'll try it
You could also try just removing the .xml files at XWD root directory along with any .ini files on the docklets folders. Should work too.
Link to post
You could also try just removing the .xml files at XWD root directory along with any .ini files on the docklets folders. Should work too.

Yeah, but has the same side effect as a new install: every settings are gone :o

And yes, like Andrew said, it's a good idea to backup your dock, if you have a nice setup but want to try new Docklets or something! It actually happens from time to time, that something crashes the dock. At least with some of my docklets, who are all far away from beeing version 1.0, and so have development status. They will get more stable in the future.

Link to post
Ok guys, I tried re-installing xwindowsdock, but after I re-install it and restart the dock I get the same error, what should I do?

Well, at least it has nothing to do with the docklets, then (glad to hear this :))

Did you change something outside XWindowsDock, between the time that it worked, and the time that it didn't work? If you deleted the XWindowsDock Folder (with all contents), i see no other reason why it should work the first time, and now on the reinstall don't. I guess there is something else wrong with your setup, outside XWindowsDock.

Link to post
Ok guys, I tried re-installing xwindowsdock, but after I re-install it and restart the dock I get the same error, what should I do?
Are you sure you deleted the installed one (the whole XWindowsDock folder and its sub-folders too) before reinstalling it? If yes there's not much we can do without knowing anything else that's particular to your computer configuration...
Link to post
I think I have it fixed, all I had to do was change where I was putting the Xwindowsdock directory

Thanks for all the help guys

So yeah, I have the feeling it was because you didn't delete the old xwd installation before installing the new one.

Link to post
Guest
This topic is now closed to further replies.

×
×
  • Create New...