Jump to content

CheckMail Docklet for ObjectDock


Smaky

Recommended Posts

  • Replies 411
  • Created
  • Last Reply

Top Posters In This Topic

Hey Smaky... This is one of those things I didn't realize I needed until I got it. lol

It is really a great docklet to have. Thank you so much for developing it.

I just have one minor problem/request... It has to do with the notification sound.

Can you change it so it only sounds when there is an increase in the number of unread emails?

Most of the time I will have a few messages sitting unread in my inbox (shopping deals, ebay, etc.),

and the sound plays every time it checks for new mail, even when the number of messages is

the same.

So now I go without a notification sound, which isn't terrible... but it would be nice to have it.

Thanks again for all your hard work on this.

Link to post

Can you change it so it only sounds when there is an increase in the number of unread emails?

I'll add such an option on the next release... thanks for the feedback.

Added option to play sound only when mail count changes (both at the total & account level), I hope this fullfils your request.

Edited by Smaky
Link to post

I'll add such an option on the next release... thanks for the feedback.

Added option to play sound only when mail count changes (both at the total & account level), I hope this fullfils your request.

Wow!!! I never expected you to do it that fast!!!

Thanks, it works great!

Link to post
Guest Di7ra

I have a problem with saving settings for docklet using OD 2 (beta) under Windows 7 (32bit). It works fine with account settings until i reload the dock. I guess it's an issue with permission rights though i don't have any problems with other docklets. I tried to run OD with admin rights as well but it didn't help. So is here any way to put in settings manually in some ini file to fix it?

Thanks for advise.

Edited by Di7ra
Link to post

I have just installed ObjectDock Plus 2 beta on my Win 7 64 bit machine yesterday. So long I did not found any issues with any of my docklets.

The only "thing" I found is that although right after installation SD+ 2 Beta did run correctly, showing all my docklets, some of them did not show their icons or behaved wierdly. I found that "somehow" OD+ 2 Beta was accessing the Docklets from my previous SD+ 1.90 install directory. After copying the docklets from the old OD+ 1.90 Docklets folder to the new OD+ 2 Beta Docklets one, all the problems went away.

Hope this helps.

Link to post

Did some more testing under windows 7. Found a couple of bugs and decided to straighten some code, but found no problems in my setup (Win 7 32 & 64 bits)

In regard to your question about manually adding the items to the ini file. The easiest way to do it is to configure your docklet as needed and then do a Backup of your setting (From the Mail Accounts tab), save the file to whatever place it suits you (like your desktop), close OD+ and open the file with any text editor (notepad will suffice). Then look for your OD+ CurrentTheme.ini file (In Win 7, C:\Users\<your_user_name>\AppData\Local\Stardock\ObjectDockPlus), and look for the CheckMail docklet entry (look for "Docklet=.\Docklets\CheckMail\CheckMailDocklet.dll" without quotes). Then copy the contents of the backup file (from ImagesFolder=icons) onto the CurrentTheme.ini (replacing the Checkmail's Docklet settings from ImageFolder=icons entry).

Do it carefully so you do not mess up your OD+ settings file.

Hope this helps.

Edited by Smaky
Link to post
Guest Di7ra

Thank you, but in CurrentTheme.ini (btw, easy way to get it: OD2 Settings -> Settings -> Troubleshooting options -> Open my OD settings folder...) i may see only some docklet settings like

Type=Docklet

RunVisibility=5

UsePopup=0

TextManuallySet=0

Docklet=.\Docklets\CheckMail\CheckMailDocklet.dll

Title=GMail - There are no messages in your Inbox

Image=.\docklets\checkmail\icons\default.png

and there's nothing about account info. Is it stored somewhere else or everything should to be in CurrentTheme.ini?

Edited by Di7ra
Link to post

Test as I mentioned... add the docklet, configure all your accounts and backup them. Then open Currenttheme.ini and unload OD+ (if you alter the ini file before closing OD+ your changes will be overwritten while unloading OD+. Then add the settings manually to the file and reload OD+.

I believe it should be something related to your setup... in my dev machine and my personal laptop I have faced no problems at all.

¿Anyone else experiencing such problesm as not saving any settings upon OD+ unload?

Link to post

When initially added, with no accounts set up that's what you would see in Currenttheme.ini. Add the docklet, configure it as desired, BackUp the configuration. open that file. Unload OD+ and then open Currenttheme.ini. Then add the backed up configuration right after the Image entry.

Link to post
Guest Di7ra

I woudn't speak here about dock with no settings as i couldn't check it then, sir.

Above you may see that i'm speaking about configured account:

[...]

Title=GMail - There are no messages in your Inbox (default is "Title=No accounts configured")

[...]

actually, i setted up gmail account, login/password info, filled up a field to start a mail program but nothing more has been wrote into the ini file.

Link to post

Would you mind to email me the .ini file?, you can replace any account info (email address, password, etc) so I can take a look at it.

BTW: I have just update the Docklet again... because of a weird bug that was related to compiler settings. Maybe that will help. Could you test it again? If not, please contact me through email to get a closer look at your setup.

Edited by Smaky
Link to post
  • 2 months later...

How do I configure my mail right!?!? I click test settings and it always comes back with "Account settings are invalid!"

I have it set up as follows:

Unique Name: ********

IMAP (show unseen/recent)

SERVER: www.Yahoo.com

PORT:993 (use SSL)

Username: *******@yahoo.com

Password: *******

Mailbox: INBOX

Program to Run: the shortcut to Yahoo Mail Log on address.

Parameters: https://login.yahoo.com/

[x] Limit program to one instance

[ ] run program automatically

[x] Run Program even when there are no mails

PLEASE GET BACK TO ME! I have never done this mail thing or any mail to desktop thing. I didn't know what POP3 or IMAP were until I Googled it five minutes ago.

Link to post

ALTHOUGH!! I do have an error to report!

When I get a New Email, the indicator isn't represented correctly. its supposed to be a red patch as is the default. But it has a grey box over it which makes it lame and maroon colored. here is a picture--

post-118196-047417700 1277365008_thumb.p

Link to post

Uncheck "Framed Background" option under the Font Settings tab in the options dialog box.

ALTHOUGH!! I do have an error to report!

When I get a New Email, the indicator isn't represented correctly. its supposed to be a red patch as is the default. But it has a grey box over it which makes it lame and maroon colored. here is a picture--

Link to post

Updated (version 0.1.1.0j) to support IMAP with Yahoo mail accounts. Configure the account to use imap.mail.yahoo.com as the IMAP mail server.

Indeed, to use IMAP with Yahoo mail you need a PLUS account, you could use POP3 though, although not as useful.

Meh. Did more research... need Yahoo Mail PLUS dontcha?! Those yahoo people suck. So I just got a GMail Account! Haha!

Edited by Smaky
Link to post
  • 2 months later...

hey smaky,

this docklet is just awesome! i'm runnning version 0.1a with tklauncher on win7 64bit and it works quite good.

i like the style of the message button and the little animation.

but still a little improvement would be nice. here a few suggestions that can be moved quickly into reality:

- one annyoing thing is whenever i click the icon it will recheck the mailstatus before opening thunderbird. to write a new mail i don't need to recheck it twice.

- if you put the recheck AFTER opening the mailprogram (lets say 10 sec) that would also solve another problem. because whenever i answer mails and close thunderbird it still says 2 or more mails in your account because it didn't recheck so quick.

- i tried to update to version 0.1.1.0j but rklauncher did not accept the docklet ("failure - not loaded"). just to let you know.

- another cool thing would be to change the little setence at top "you have x messages in your inbox" - i just like to see the number of messages.

- it would be also nice to have an option to make the number of messages at the icon a little bigger or at least bold - it looks just too tiny in that red dot.

best regards

fredellini

Edited by fredellini
Link to post
  • 3 months later...

ALTHOUGH!! I do have an error to report!When I get a New Email, the indicator isn't represented correctly. its supposed to be a red patch as is the default. But it has a grey box over it which makes it lame and maroon colored. here is a picture--

Uncheck "Framed Background" option under the Font Settings tab in the options dialog box.

I have the exact same problem, and this did not fix it..

I tried to look for any settings in the OD2 itself, but nothing really grabbed my attention as relating to this.

I'm still using your version "h" though.

It's not just lame maroon, but even the number is dark grey, which makes it very hard to read. It's like a shadow placed on top of the message indicator icon. I got the same version running on another PC in OD1.9 and this is not a problem there.

Link to post

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...