Jump to content

Network Monitor for ObjectDock


Smaky

Recommended Posts

half,

the icon itself is something that I am not sure how to accomplish... since the graph would need to be skewed & oriented to match the monitor. Another issue is the small area that is available for it... specially for the monitor in the back. whose screen is only shown partially.

But maybe I did not get your idea right... do you think you can create mock-up of what you have in mind?

Another issue is that I haven't got permission to use the icons from Domestos (he never responded to my requests), right now I am waiting for a couple of contributions from two guys in the community... but I have to wait until I get the finished icons to work with.

What I did was to add the option to show a graph of uploaded/downloaded layered on top of the icons... I don't know if that would suffice.

You got the idea right, and it would be some work to orient and skew the graphs and yes, the rearmost monitor is only a partial screen, so the graph area would have to be narrower.

I like your solution showing the two graphs...my suggestion would be to eliminate the graphic of the two monitors and just show the graphs...it's kinda hard to see them with the picture of the monitors overlayed

Link to post

Half,

Ok... I got It... I will add an option to show/hide the monitors... so It would be up to the user to decide.

On the other hand... I will not abandon your request... I will have to research on graphics manipulation to find a way to ajust the graph to the interior of the monitor... but I do not really know how long would that take.

Link to post
  • 2 weeks later...

The updated docklet will let you hide the icons... I am still not sure if I will ever get the graph rotated... but if I find some time to think it out... who knows.

Thank you for your feedback.

I like your solution showing the two graphs...my suggestion would be to eliminate the graphic of the two monitors and just show the graphs...it's kinda hard to see them with the picture of the monitors overlayed
Link to post
  • 1 year later...

I have updated this old guy. I now properly scales the graphs to support connections over 1 MB. I have also added serveral options to make it more skinnable like an easier icon selection tab, font color, size and transparency. Tested under Windows 7.

Link to post
  • 5 months later...

Hello!

First of all: your Docklet is great, I love it!

Sadly: it stopped working about 1-2 weeks ago :-( Apparently I'm the only one having that issue (according to Google search results at least ;-)) so I'm kinda clueless what the reason for this behaviour might be. Do you have any idea how to fix my problem? Maybe you could tell me on which (system) files your docklet depends so I can try to fix it myself (considering the possibilty that I might have altered a system dll or something which is needed)?

Thanks in advance.

Link to post
  • 3 months later...

Hello!

First of all: your Docklet is great, I love it!

Sadly: it stopped working about 1-2 weeks ago :-( Apparently I'm the only one having that issue (according to Google search results at least ;-)) so I'm kinda clueless what the reason for this behaviour might be. Do you have any idea how to fix my problem? Maybe you could tell me on which (system) files your docklet depends so I can try to fix it myself (considering the possibilty that I might have altered a system dll or something which is needed)?

Thanks in advance.

Would need more info to figure this our (OS, OD version, etc).

Link to post
  • 4 weeks later...

Would need more info to figure this our (OS, OD version, etc).

Oh, right, forgot the basics :)

OS: Windows XP SP3

OD Version: 1.9.0.535(according to the *.exe)

Windows Firewall: active (disabling doesn't help)

Security Software: Avira Anti-Virus 10 (the docklet already stopped working while I still had Version 9, worked fine before along with Avira though)

Removing and re"installing" the docklet didn't help either (I didn't re-install ObjectDock though)

EDIT: I tried the updated docklet version over here as well as the previous version which I still had on hd and neither of them worked.

Since I can't really tell when exactly it stopped working I can't track down what might have caused the problem. Does it rely on something in the Documents & Settings folder and/or the Program Files folder (ObjectDock itsself is installed in an entirely different location)? Because I moved the first and created a junction point for the later which did cause a few programs to behave a bit weird (mostly because of the junction point).

I could also imagine some Windows Update ruining it? Maybe it replaced some original dll with a newer version which doesn't work with the docklet.

Also, I did have a rootkit (successfully removed) once, so this might be another hint for some broken system files (I did sfc /scannnow though so they *should* be ok).

I'm willing to investigate the issue myself since this is very likely a problem based on a very specific setup I have over here so reproducing it might be almost impossible. So if you'd tell me what dll's or windows services your docklet depends on I could try to track down the problem and report what the issue was once I could fix it. Of course it's perfectly fine if you don't wanna tell me how your docklet works and stuff :)

Another thing I'm going to try (when I have a bit more spare time) is installing ObjectDock along with your Docklet in a Virtual Machine in VMWare to see if it works in there or not.

Thanks for your help in advance.

Edited by Sentenced
Link to post

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×
×
  • Create New...