Jump to content

Finderbar - Problem with fonts and transparency


Recommended Posts

Hello guys!

I already searched through AS but didn't find anything like this.

I use FinderBar to emulate the Leopard taskbar on Vista (yeah i know :P ). But I have a problem with the fonts used and the transparency of the Aero GUI. Take a look at the picture in the attachment.

This non-antialiased-effect of the fonts are not due to the jpg compression. It's the acutal look and I would like to know if there is a way to fix this.

I already tried to change the font, the fontsize and the fontweight but that didn't change anything.

Thanks,

BlaZeOSX

Edit: The compression was too strong, the actual effect got lost ;) Here's a new one.

And I assume now, that this effect is due to the clear type. What do you think about it?

post-84894-1217786482_thumb.png

Link to post
  • 2 weeks later...
  • 2 weeks later...
  • 1 month later...

Since Landvermesser doesn't reply to my messages I try to post the solution here. As I already said, the problem is most likely caused by the ClearType of Vista. But fortunately Microsoft provides all developers with a nice tutorial how to disable ClearType in their applications or how to change the quality of it.

http://msdn.microsoft.com/en-us/library/ms533912.aspx

In addition there is an example how to implement this code into a program:

http://www.delphipraxis.net/topic43653_mic...ype+einaus.html

So PLEASE Landvermesser, remember the users of Finderbar on Vista and implement the ClearType disabling into Finderbar.

Link to post
  • 9 months later...

I found out something that might help everyone with this problem!

I had this same problem, but when I went here: Control Panel > Appearance and Personalization > Personalization > Windows Color and Appearance, then clicked on "Open classic appearance properties for more color options"...Clicked the button that says "Effects" then clicked the drop-down list below "Use the following method to smooth edges of screen fonts:" and then changed it from "ClearType" to "Standard", IT FIXED THE PROBLEM! I saw barely any noticeable difference in text quality.

Hope this helps you, and that you are satisfied!

(If you are super-picky about font-smoothness, then this is not for you stupid, ignorant people!)

Edited by STARTxAxFIRE
Link to post
(...)

Hope this helps you, and that you are satisfied!

(If you are super-picky about font-smoothness, then this is not for you stupid, ignorant people!)

If you(1) are super-picky about font-smoothness, choose among these options:

  • Use ObjectBar or Rosie or McBar instead, for finderbar emulation.

or

  • Use GDI++ instead, for font smoothing (this choice highly recommended) (I recall some modes of it do subpixel -i.e. "ClearType").

(1) by "you" I don't mean STARTxAxFIRE, I'm just quoting and kind of adding info. :P

Link to post

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×
×
  • Create New...