Jump to content

Setting up VMWare with Existing Boot Camp Installation


Recommended Posts

Hey everyone,

Was curious as to what approach I needed to take to set up vmware to use my already installed windows installation or if it was even possible.

The assistant wants me to set up a whole new virtual folder and install it again which seems kind of redundant.

If there's a way to direct it to my boot camped partition that would be great.

Thanks in advance for any assistance.

------------ EDIT

Sorry guys, I'm really dense, i restarted the program and the partition was added to my list lol.

In any event thanks for the help!

------------EDIT 2

New question! Though it's off topic with this now, if someone could change the title that'd be great.

I'm running xp full screen in one of my spaces, and whenever I go to play starcraft it doesn't stretch to fit like it did if I ran windows natively. It shows full screens but runs the original 640 x 480 window in the middle. Was wondering if there was a way to fix it so that running the game would stretch to fit like it did.

Thanks!

Link to post

I appreciate your intuitive assistance. It's nice to see the community is fledging with "younger" members that find it clever to make generic cliche internet references as apposed to actually answering my question.

In the three years I was here before you were even a member, a larger demographic of people around here were actually willing to assist their fellow community member.

Times change I take it.

Link to post

Sadly they do :(.

And, I hope you are using VMWare Fusion + Bootcamp, yes? If it's an nVidia based Mac (eg, MacBook Pro) then install the nVidia Control Center inside of Windows. That will let you choose between centered (what you are experiencing), Maintained Aspect Ratio (has bars on the sides of the screen to match the 5:4, 4:3, 16:10, or 16:9 ratios), or stretch, which would take the current displayed resolution and stretch it to fit every pixel on your screen.

Link to post

I found this http://communities.vmware.com/docs/DOC-1201 and the full screen line that you add to the preferences text file works. But still keeps it in 4:3 so there are black bars on the left and right still.

I'm on an iMac with a radeon card instead though. Or else I'd try out the control center and try to make it stretch to widescreen.

Perhaps there's something you can add to the line of code they suggest?

pref.autoFitFullScreen = "fitHostToGuest" maybe replace fithosttoguest with something that makes it stretch specifically to the resolution I'm running; or at least make it widescreen.

Link to post
I appreciate your intuitive assistance. It's nice to see the community is fledging with "younger" members that find it clever to make generic cliche internet references as apposed to actually answering my question.

In the three years I was here before you were even a member, a larger demographic of people around here were actually willing to assist their fellow community member.

Times change I take it.

Oh well, not everyone can be old and "experienced" like you. Why not build a time machine and jump back 3 years to ask your question so i don't need to see your posts. I was only giving my opinion anyways, couldn't give a **** if you use it to your benefit or not.

Link to post

Clever comeback, however, your opinion regardless of how fleeting it may be can remain in general discussion. There's more to life than telling other people what you think about things. Go volunteer for a needy country or something.

Link to post

I installed CCC and have been fiddling with it for awhile but can't seem to get it right. There's a setting in the video portion about a "theater mode." I've been trying different settings and doing a lot of rebooting but it hasn't been quite right.

Right now it's stretching to fill the screen, but it's going beyond my resolution rather than fitting to 1920x1200 so the game has little scroll bars to let you move around to see the rest of the screen. So it looks like it's stretching it to fit the width, but rather than distorting it, it's maintaining 4:3 and it's too tall.

----EDIT

I ran the control panel in VMWare and while you can't edit any settings of course, the display adapter in the drop down list is different. Natively it shows my video card while in the virtual environment it displays "VMware SVGA II" so I don't think editing the card natively would fix it.

So I'm back to square one again I guess.

For some reason the highest resolution setting in VMWare is 2360 x 1770 so I think whenever I run starcraft it's stretching it to display that large.

Link to post

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×
×
  • Create New...