Jump to content

RunMe 0.9 (Application Launcher)


KSoft

Recommended Posts

@GSpot,

If you choose this file check checkbox at bottom of open file dialog (If you can't see this box, resize open dialog a bit).

Then file name will be saved as "%DISC%Documents and SettingsgspotDesktopRunMeDOCUMENTOStest.xls"

But on other PC you will not have this path also.

Please place all files on Flash drive to, for example, "H:docs1.xls" and then add it to runme as relative link.

You will have "%DISC%docs1.xls" and this path will be independently from disk letter.

Hope this helps :)

Link to post
  • Replies 178
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Posted Images

@GSpot,

If you choose this file check checkbox at bottom of open file dialog (If you can't see this box, resize open dialog a bit).

Then file name will be saved as "%DISC%Documents and SettingsgspotDesktopRunMeDOCUMENTOStest.xls"

But on other PC you will not have this path also.

Please place all files on Flash drive to, for example, "H:docs1.xls" and then add it to runme as relative link.

You will have "%DISC%docs1.xls" and this path will be independently from disk letter.

Hope this helps :)

In part it helps! It’s “disk independent”, but not “path independent” (i think).

I need to be able to copy Runme (with documents in the Runme directory…), for example to several pc’s desktops, and the links still work…

Can this be done?

Thanks for all the help

I love RunMe :-)

Link to post

@Gspot,

It seems to me that there are bug with file icon (not in Windows, sure ;))

For now, you can try to move your RunMe folder to disc root (and documents in it's folder) and add documents to RunMe with relative check box. If you choose image from this folder (png, with the same relative flag) - it should work.

I should fix it than I will have time.

Link to post
@Gspot,

It seems to me that there are bug with file icon (not in Windows, sure ;))

For now, you can try to move your RunMe folder to disc root (and documents in it's folder) and add documents to RunMe with relative check box. If you choose image from this folder (png, with the same relative flag) - it should work.

I should fix it than I will have time.

I was already doing what you suggest “move your RunMe folder to disc root” :) It work’s.

Yes it’s in Windows.

Keep up the good work

Thanks

Link to post

I'm curious if Environment Variables or Shell Namespace Objects are acceptable for paths... fe %UserProfle% or shell:Programs.

Testing, shell:Programs seems to work as "Link" or "Disk or Folder" provided "As Menu" is not ticked, %UserProfile% doesn't work at all.

And about the "Scroll button", yes, I knew what you meant. I have a left button, a right button and no scroll wheels middle mouse buttons or scroll buttons. Nor do I intend to give up my custom pointing device to acquire some cheep scroll wheel which only does the same as the one on my keyboard, or an extra mouse button.

I guess I could macro the eMail key or something to send middle mouse button signal to Windows with AHK or AutoIt, seems like a lot of effort however. Can't we just have a configurable click (ctrl + left click, etc) for that function? Just to be backward compatible for people (like me) who think Apple have the right idea not complicating the pointing device with 1000 + 1 fancy controls you never normally use? ;)

What will we do when we are all using tablet PCs, many of them don't have any buttons on the stylus. (Okay keyboard combinations with no keyboard isn't really happening either but you get my point. Different people work different ways and prefer different devices.)

Link to post
  • 1 month later...

Err... version 0.9.2 is available as a Zip from http://www.ksoft.nm.ru/... scroll down to RunMe.

There is no installer as yet. Just extract to C:Program Files or C:Program Files (x86) as appropriate and run from there.

Right click any menu item and select Settings, on the options tab, the bottom tick box is for starting at login... there are other ways to achieve this, but that's all you need to do.

I don't know of a Version 0.9.2.1... Konstantin could know more / better. ;)

Link to post

You're all most welcome. And yes I'm still keeping tabs here.

Just to confirm, both KSoft download and Aqua-Soft forum exe only provide the same exe Version 0.9.2(.1)

File hashes (exe file):-

MD5 = 213C24AA5FF1761A7AB416C445E5C713

SHA1 = B4D4F15907378C3AA9467C137BDADA3AB2BC7023

If your exe hash doesn't match, it's either a different version or infected. ;)

Link to post

I have found an annoying bug from my setup. I have the RunMe set on "Slide in on mouse click'.

When you press the mouse button down and drag it towards the edge of the screen when RunMe lives, it will appear without being clicked on.

This is annoying when drag and selecting a lot.

Link to post

Are you sure you're using the latest 0.9.2 version?

I remember something similar, but can't reproduce it now... just in-case, it might help to know which theme/skin you are using and what side you are docking RunMe?

Digression

I do notice that selecting "Slide Out On Mouse Leave" happens regardless of the check box state... and that weather measurements are either "English" or "Metric"... well I'm English, and all our weather, temperatures etc are quoted in Metric... we haven't used imperial measurements for many years, except in our pubs (as in "a pint of beer") and road signs (Miles as opposed to Kilometers).
;)

I believe only the Americans, and then probably not the Canadian ones still use Fahrenheit, and their interpretation of Imperial quantities is different from the English. So I'm guessing the term should be Metric or U.S. Though you could use the term "Imperial" if it turns out some nation of the former British Empire or perhaps former British Commonwealth nation does still use that measurement system for their weather... Of course I have no idea how Mexico, and other non-US American nations measure temperature, but I think many of them do use kilometers on road due to their connections to Spain, and their former empire.

And to all those who live in nations still suffering the legacies of my nations former Empire, on behalf of my ancestors, I do apologize.
:(

There are many little inconsistencies like this in the program, and I imagine there will be till KSoft reaches a version 1.x of RunMe. It's good to note them, but we also need to be able to reproduce the effect in order to fix it. Is anyone else having this trouble and can you share what configuration you are using?

Cheers.:D

Link to post

@Jlix, it occurs because RunMe should be opened if you drag and drop file to make link. That is it? File or just mouse button pressed will be known after you release the button. Or I just don't know how to make better. Maybe it would be better to make "lock" option in main menu to lock all drag, drop, move and delete features.

@Bobsobol, I am afraid that there will be still many discrepancies and after 1.0 version :)

On weather, I have spyed such translation here:

http://www.weather.com/outlook/travel/busi...rom=search_city

(after Save Location link) In Russian translation I used "Fahrenheit" and "Celsius" and I think it's right.

Link to post

Ahh, Ja. En Deutsche sprechen das Wettervorhersage ist en Fahrenheit oder Celsius. Das ist her gut.

Unlike my German which is only so-so. Fahrenheit and Celsius is a very scientific description of the two measuring systems, and therefor a-political, which is better considering the wide variety of what is considered "politically correct" around the world, even within the same language.

I can't get RunMe to produce what I guess would be Фаренгейт or Цельсия, even though my system supports Cyrillic type, as I think RunMe is not a Unicode built application. All I get are ??????????s. lol

That's normal with Delphi, and I can't find an easy way to do Unicode apps in C++ Builder either... From what I can gather Lazuras produces true Unicode executables, and can build to 32 or 64 bit applications. But I'm not sure how easy it would be to port your GDI Plus controls from VCL to LCL.
(Lazuras makes me green with envy, I want a C++ version of it.
;)
)

In Britain we also use "Centigrade" to refer to metric temperatures, but I can't promise that that is so with all English speakers around the world, where I'm pretty sure we would all understand Celsius.

As to Drag and Drop, I've not found a way to make this work well, since the menus disappear as soon as you select icons in Explorer or Fileman, and don't return when you drag files over the tab. If I drop them on the tab, they appear in the start panel (which is never where I want them) and in no particular place on it... each time I drop they come up somewhere else.

I just accept this as part of a work in progress.

I can't drag items from RunMe, to it's self (to re-order items) or to the desktop (to create shortcuts)... but since you can cut and paste items in RunMe with a similar end result, I presume this is normal behavior too.

Link to post

Thanks much, Nikos! :)

I've added translation to RunMe archive on my site and updated Author to Nikos Georgousis.

Bobsobol, AFAIK, there are some components (TNT) for Unicode in delphi application but I can't use Unicode to draw strings on main RunMe's menus. For example, Arabic works well on settings form but not in RunMe window.

I don't understand German at all :) but I think that people who uses C or F know that is this since the childhood.

Lazuras seemed to me very friendly, but as you have noticed about GDI+, I have some lifelengths in Delphi and maybe Lazuras would be good for absolute other, new applications? :)

Link to post

Yes yes... I completely agree. I'm quite attached to some of the compilers I use, but I'm always on the look out for something more cross platform. I think essentially, I'd like something that can encapsulate Mozillas XUL UI into the VCL hierarchy.

lol... never mind we can dream.

BTW... what timing component / API are you using to time the animations? Perhaps I could research alternatives for you... with regard to the speed differentials depending on what other windows are in memory, or help debug ones you find on alternative hardware.

Let me know if you want a Beta tester. ;)

Link to post
  • 1 month later...

I like this app launcher!! *v* and i've created a skin as well.

http://www.aqua-soft.org/board/attachment....=1&d=1220532483

but i'd like to give some suggestions.

1) it would be great if we can customize the font, icon , item size and width of the submenu. As the submenu style now is inconvenient for those who have lots of files (me...), so i'd like to have a submenu like this -> http://www.aqua-soft.org/board/attachment....=1&d=1220532483

2) if we right click the item of the submenu, the context menu would be showed or we can cutomize it ourselves. It would be much convenient than showing the "Find Object" button and "Context Menu" button.

3) i would like to add a "Open This Folder" button in each menu. You can take a look at this pic -> http://www.aqua-soft.org/board/attachment....=1&d=1220529950

In each submenu, there is always a button on top and which is to open the previous folder.

Besides giving suggestions, i have few questions as well.

1) I do not use any shadow and stroke, but the font is quite unclear, it is like there's shadow behind.. I don't know how to explain, but you can see it here -> http://www.aqua-soft.org/board/attachment....=1&d=1220532483

2) There are large spaces on the top and bottom of the submenu. how can i customize it?

Thank you very much!!

post-39-1220532749_thumb.png

post-39-1220532748_thumb.png

post-86939-1220532748_thumb.png

Link to post

Hello, nhtatAquaSoft,

Thank you very much for interest to RunMe's themes!

Sorry, I was absent for a long time. Cool skin! :)

1) it would be great if we can customize the font, icon , item size and width of the submenu. As the submenu style now is inconvenient for those who have lots of files (me...), so i'd like to have a submenu like this -> http://www.aqua-soft.org/board/attac...1&d=1220532483

If I understood right that you use earler version of RunMe (not v0.9.2.1) where was simple system submenu. Am I right? I mean that in last version this sub menus will have the same style as main menu. I а you mean settings explanation then please let me know.

2) if we right click the item of the submenu, the context menu would be showed or we can cutomize it ourselves. It would be much convenient than showing the "Find Object" button and "Context Menu" button.

I think that I should make option for this context menu. I only want to leave "Find Object" but we really can have item to open folder (as in next suggestion) and/or find object on middle mouse button click.

3) i would like to add a "Open This Folder" button in each menu. You can take a look at this pic -> http://www.aqua-soft.org/board/attac...1&d=1220529950

In each submenu, there is always a button on top and which is to open the previous folder.

Good idea, maybe better than middle button click :)

1) I do not use any shadow and stroke, but the font is quite unclear, it is like there's shadow behind.. I don't know how to explain, but you can see it here -> http://www.aqua-soft.org/board/attac...1&d=1220532483

I think this can be font smoothing. But I should see theme (it's settings) to know precisely.

2) There are large spaces on the top and bottom of the submenu. how can i customize it?

Please see Noire theme PNG files. There are "back" for submenus header and "mainheader" for top part of first main menu. Use "TopSpace" value for vertical alignment of submenu with previous menu.

Thanks again!

Link to post
  • 2 weeks later...

Hello KSoft,

Has there been any progress with an option to lock the drag and drop function as this is still annoying me every now and then?

I also get RunMe closing on me randomly, i have no idea on how this happens as i go to use it and it has gone. It happens proberly once every two to three weeks, but i can not be any more help than that.

Thanks

Link to post

Hello, jlix, :)

Hello KSoft,

Has there been any progress with an option to lock the drag and drop function as this is still annoying me every now and then?

You can try this new EXE (v0.9.2.2). There are new Lock menu item in main menu to lock draging of RunMe's items.

http://ksoft.nm.ru/runme0.9.2.2exe.zip

I also get RunMe closing on me randomly, i have no idea on how this happens as i go to use it and it has gone. It happens proberly once every two to three weeks, but i can not be any more help than that.

Thanks

Please let me know how it will works because it's a new version and there are some new bugs, not only new features (like system context menu for files in folder sub menu, 2 new animations for sub menus and reversed speed sliders in settings, will be fixed soon).

Thanks!

Link to post

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...