Jump to content

Stacks Docklet

Recommended Posts

  • Replies 1.9k
  • Created
  • Last Reply

Top Posters In This Topic

Hi everyone,

Just found this docklet, and I'm seriously impressed with it! Extremely useful :) I'm using it with ObjectDock, just for information..

One issue I noticed was when you have 'follow the dock' turned on, it lags the dock terribly, sometimes locking it up completely for more than three or four seconds.. It's not a CPU issue, since none of the cores of my cpu climb higher than 40% (2GHz mobile core 2 duo).

It only happens when the stack has to move.. The dock acts like normal when i'm moving the mouse over a section that doesn't cause the stack's base to move (ie, if the stack is on the left end of the dock, moving the mouse at the right hand end where it doesn't affect the open stack doesn't cause any issues).

I presume it's something to do with redrawing the stack, or sensing the position of the stack base..

For reference, i have the latest version of the special folders stack, and the latest version of OD. I have magnify enabled on the dock. Dock is at the bottom of the screen.

Not pushing for it to be fixed asap :P just something to take note of and maybe try and fix in the future..

Link to comment

@RocknGothAlien: I can confirm that, with RocketDock any change in monitor number (from two to one and viceversa) makes the stack docklet stop working. A restart fixes that.

About the "follow the dock" behavior, the movement is not smooth altogether, also under RocketDock in my case, Vista Ultimate SP1 on an Intel Core2 Duo 2.4 Ghz with 4GB RAM and an nVidia Quadro FX1600M graphics card... which should be enough horsepower to make it run ok, I believe. I don't have autohide on, but I have RocketDock layering set to Normal and Popup on mouseover.

Link to comment

I can't improve it more without cooperation from Object Dock.

I can improve it a little more if user has auto-hide dock disabled.

That's ok. I thought it might be an OD-side issue, rather than a stacks issue.. I do have auto-hide on, so i can't really do anything about it..

Thanks for the prompt reply though :) Nice to have developers talk to the people who use their plugins :)

If you're ever after a tester for OD, i'd be happy to put my hand up, just by the way. I used to use Y'z dock before it stopped being updated..



Link to comment

Nice little add-on. Works pretty good for the most part, I ran into a few bugs though.

First off I am using:

Objectdock 1.90 free Build 536

Vista Ultimate w/SP1

1. If you have multiple stacks on the dock and you click one then click another one without clicking the first one to close it, the dock locks up (will not hide and just shows the text from the first stack, thus having to close it and re-open it to work properly again) I can make a screenshot if you need one.

2. If I change the resolution of my monitor with Objectdock open none of the stacks will open. Closing Objectdock and re-opening it fixes the problem.

This is a problem for me because I have dual-monitors and a projector hooked up (via a switch) and I change my resolution for the projector daily.

For now I have a hot-key set to close Objectdock and re-open it.

Link to comment


I have no way to reproduce the error.

Please do this:

Create a new Word document, and paste there each file / folder name in a line by itself.

Then send it to me (upload it somewhere or use the attachment function of Aqua-Soft in advanced post options).

This way I can then make a folder and add all files / folders with the names and reproduce (and hopefully solve) the bug.

Link to comment

I suppose I would put this into a separate reply:


Thanks for the .pdf file. It was very useful.

At first, I tried and stacks just shown ?????? question marks.

Then noticed I was doing stupid stuff with unicode (I don't use big5/latin1/whatever encodings, just unicode instead, but I was forcing an encoding at some point... me fool hahaha).

Ok, so I fixed that, got chinese chars in the stack, and didn't notice any strange letters.

I've reuploaded the fix here:


Try it and tell me if it works.

Link to comment

just in case it helps:

current version crashes as soon as i click 'icon settings'.

so i tried the old version and created a stack with only shortcuts in it, chose a vista icon for it (imageres.dll in the windowssystem32 folder). when i apply these settings, the icon disappears, but rocketdock still recognizes it --> there is a 'blank' space on the dock instead of the icon, and when the mouse cursor is over it, only the name of the folder appears but i can't click on anything).

then i turned to the oldest version which works fine and gives me satisfaction.

i'll come back in some time in case a new stable version is released.

Link to comment

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now

  • Create New...