Jump to content

Stacks Docklet

Recommended Posts

  • Replies 1.9k
  • Created
  • Last Reply

Top Posters In This Topic

Help anybody,

I've downloaded the latest version of matonga's 'Stacks Docklet'. Its perfect on ObjectDock, no problem at all. But now, I'm using RKLauncher. I've encountered some problems using 'Stacks Docklet' on RKLauncher, such as;


On the first image is when the 'Stacks Docklet' is added and on the second one is when its right-clicked and the browse button is clicked. Other than that, the wanted image for the docklet doesn't appear and when I tried to move the position it suddenly disappears or RKLauncher suddenly closes. Please help.

Warmest Regards,


Link to comment
You have to delete all stacks from RKL, then install an older Stacksdocklet.dll before 13.11.2008.

Then you can add them to RKL. SHould work now. Close RKL. Update Stacksdocklet.dll and it should work.

Just the adding isn´t working. I added v244, which I tested with RKL and is working.

Damn, don't get it, It still crashes when going to the setting window.

Link to comment

I am in the same boat. I am using RKLauncher (the most recent version from http://home.cogeco.ca/~rklauncher/). When I insert the stack docklet, every time I click to get to settings, or left click it, the RKLauncher crashes. I have tried pulling it out, removing the docklet from RKLauncher entirely, and readded it, still nothing. once, Once I got it to work (not on the first try though), then it crashed and it has not worked since. I don't know why it worked the once. I am going to try other docks.

Link to comment

As an update, I just installed Rocket Dock and tried using this docklet in there, same issue. The icon shows up, I right click and then select "icon settings" and then the program crashes. It also crashes if I left click. I am using the Current version: http://matias.securityconsultant.com...et-preview.zip version).

However, when I use the If you experience crashes while using it, please use this version instead:

http://www.aqua-soft.org/board/showp...postcount=1603 (thanks Björn) version, it seems to work. I think that I was using this version when the ONE time it worked happened on RK Launcher.

I am able to get Bjorn's version to work with both RocketDock and RKLauncher.

Thanks so much Bjorn!!!!!! You're rocks!

Link to comment

For those of you who are crashing when you click on "icon settings" with the latest version, this was happening to me on Vista x64 until i ran RocketDock as an Administrator once. After that it has worked perfectly. Give that a try and let us know how it goes. Obviously this is not a solution for XP users, sorry.

Link to comment

I know it's a stupid question but where can I find the different download versions?

I would like to use Stack dock because I love it but every time I restart my computer it forgets my settings and I have to re-do everything.

I use RocketDock 1.3.5, Vista 64, and I don't wich version of Stack but I downloaded it roughly one month ago on the RocketDock website. Sorry for my bad english

Link to comment

For Vista it's enough to install RocketDock (or any other app with the same problem) to a folder which is NOT "protected" by the OS, for example a "tools" folder like C:Tools or whatever you like, then there will be no access rights issues like not being able to save settings etc. I've always had my installation under C:ToolsRocketdock and never had any issues either with Rocketdock or the Stacks docklet.

Link to comment

I found a MAJOR bug on the current version of the stacksdocklet [today is November 24, 2008 just for reference]. Okay so far I got the latest version of the docklet and moved them to my OD+ folder. I had one stack for my User folder and it only shows the AppData folder, an Apps folder I created, the Games folder, and a shortcut to the public folder. But the thing is it doesn't show the System Folders like Contacts, Desktop, Documents, Downloads, Links, Music, Pictures, Searches, Favorites [renamed to Sites], and the Videos folder. This is a major problem that wasn't present in the previous version I had.

Another bug I found is if you delete the stacks from the dock, as in dragdrop&poof, its gone but after you close the dock and restart it it reappears again. This shouldn't happen and i just wanted to let you know.

And the following are request please think them over Matonga;

1: To add the option to enable/disable hover over text effects, because to me it looks better and thats the way it is in Mac OS X.

2: This may be a bug or done intentionally but, when you open the stack the icon set for it disappears then reappears when the stack is fully open, when closing it it still stays there. Can you please make it so when you open the stacks the icon doesn't disappear? Thnx

3: May be you can implement this in the future, but in OS X.5.4 the stacks got upgraded and was given the "List feature" that behaves like a menu in the windows taskbar, like quicklaunch for example, when theres a folder in that folder it expands and shows what's in that folder. Apple included this because of consumer demand and this is a real great feature. Notify me if you have questions about this.

Thankyou and please look at this and notify me on what you think. You're a great developer and I know you can pull this off. Also nice job on the live previews for the stacks. Thankyou and please message me on your thoughts questions and so on.


Link to comment

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now

  • Create New...