Jump to content

need old version of firefox!


Recommended Posts

i want to have a safari browser on windows---read about it...i know the best way is skinning firefox. but as i kicked away my old firefox cause it didnt work yesterday when i tried skinning it i need an old working version again. today i saw that only the new 2.0 version is available which obviously is not compatible with safire or whatever is the ebst firefox safari skin.

so which old firefox version is the best to handle with safire? where can i get it?

Link to post
  • 2 weeks later...

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×
×
  • Create New...