Jump to content

Macbook Airport


Recommended Posts


I just got my macbook today. I am trying to get into my wireless router. I have WEP as my security mode. I can join to the network with the dell laptop easily. I just enter the password and it connects. But, using mac, it is saying that there is an error.

Can someone please guide me step by step?

I would appreciate that.


Link to post

What error do you have ?

I had the same pb at my girlfriend's and i couldn't connect either even if I had had the WEP key and stuff.

But I have another pb here at home, my airport often disconnects without any reason. My wireless just works very well with my windows laptop and desktop but my macbook just keeps disconnecting all the time and it is very annoying. I tried changing the channel and I recently downloaded the Apple upload about the airport.

Does anyone has a idea or solution ?

I hope your pb will be also resolved very soon SciFi ...

Waiting for your answers you apple guys :-)

Link to post

I know this problem

Current macbook can only use WEP with the 1st key. If your wireless is set to use other key you will always get an error...

And this is from some googling:

OK, it worked. You're a genius, you and everyone else who responded. Thanks so much.

Here's how I fixed it:

- I SKIPPED the network setup assistant.

- Instead, I used native system preferences, then clicked network.

- I clicked the + sign to add a network

- Typed in SSID of my home wireless network

- (IMPORTANT) in the field below, I was able to specify 128 bit WEP hex ***** HOW COME I DIDN'T SEE THIS OPTION WHEN I USED THE NETWORK SETUP ASSISTANT? ***

- applied the changes, and I'm on.

Sounds like the network setup assistant has some limitations?


Link to post

Okay, yesterday it worked but from today...when I connect to my wireless Linksys WRT54GS router, it connects. But, after a while later, my desktop which is wired does not work then I have to reset the router again. The internet does not work.

I dont know why this is hapenning.

I guess i got the same problem as etnik04.

P.S: I bought the router 2weeks ago and it works with the dell laptop. I got it from PCRichard and Sons. I dont think there is anything wrong with the router.

Link to post

Thanks for the help guys.

I reinstalled the router and downloaded this program called EasyLink_Connect from Linksys's website. It went step by step and configured everything and enabled WEP 128bit hex. I changed the router's network mode to G-Only. Since then I am not having any problems. Everything is fine.


Link to post

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...