Jump to content

"Beta" of AveDesk 2


Recommended Posts

I'm not able to use this with vista. Avedesk launches just fine and I can add desklets, but they do not appear on the desktop. anyone have any luck vista?


In case it helps anyone, I finally solved my problem. I had to change the style setting under appearance to "normal window" rather than "desktop icon.

Link to post
  • 4 weeks later...
  • Replies 150
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Posted Images

  • 4 weeks later...
  • 2 months later...

My experience with AveDesk 2 for Vista is good for the most part, but I had to uninstall it after a number of crashes.

Like I said, for the most part it works very well. But...

- Sometimes when vista first loads AveDesk will crash or hang. Stop the process and restart - works fine. But this becomes a problem after it keeps happening.

- Avedesk will sometimes crash when I save or load a theme. I lose everything and have to start over from scratch. *This is what finally made me stop using it.

- I also had major problems with modules like automounter and desktop grabber. Crashes when loading or uninstalling.

If anyone knows how I can stop some of these bugs from happening please let me know because Avedesk is one of my favorite programs! I mainly use it to create osx like icons (changing position of the text to right side, hd icons and info on desktop etc).

If anyone knows of another program I can use for this... drop me a hint :)


BTW - I only run vista from the admin account (you have to manually turn it on). When running Avedesk from a user account I had to let the program run as admin to get modules to work at all.

Link to post
  • 3 weeks later...
  • 2 weeks later...

I was using avedesk 1.3 for a very long time, i just stumbled upon this topic. i immediately downloaded the package and "installed" it. Everything seemed to work fine until i wanted to acces te options dialogue. everytime i do, i get this error:


after klicking "ingorieren" (means ignore ;) ) several times everything seems to work fine again. is there a way to fix that?

using winxp sp2 german.

Link to post
  • 2 weeks later...
  • 2 weeks later...
  • 2 weeks later...
  • 4 weeks later...

nice ... the beta looks kinda ruff and there really aren't many changes from 1.3 but it seems to start a little faster and also it seems to use a little less ram. Which is really hard to find in new versions of software.

Anyway it looks like 2.0 would be an even better release. Maybe it needs an installer this time around. New users always ask how to install this and while I don't mind explaining an installer would do a much better job.

Link to post

I've been having some problems the last couple of days, one of my desklets has no image, the label is visible however. I can fix it by restarting AveDesk or by reloading the images (vista icons in this case). I have a feeling this has something to do with the Vista's superfetch/prefetcher as it only happens when AveDesk is automatically started, when I let Vista boot up fully and then start AveDesk by hand everything is fine. I have no languages folder and the pidshortcut update is installed (the desklets are set to Always-On-Bottom).

P.S. it's not always the same desklet, seems to vary

RESOLVED: I emptied the prefetch folder and everything is hunky dorie again. I wasn't sure if I could just delete the contents of the prefetch folder under Vista but this is no problem.

Link to post
  • 5 months later...
  • 1 month later...
  • 3 months later...


Hi, I have a serious issue :/

All things worked well, since I've reinstalled OS. Old package is not working, so I've tried to build it up once again - I've downloaded 1.4, unpacked, overwritten with 2.0, Languages deleted, with new PidlShortcut, Translator from those RARs provided. But when trying to launch, I'm getting attached error :( (alternatively at http://mirandapack.ic.cz/pictures/atlcomcli.jpg)

What I have installed:


Visual C/C++ redistributable package 2005 (tried both, original and SP1)

Visual C/C++ redistributable package 2008

Visual Studio 2005 (with C++, C#, J# + SDKs, .NET SDK)

.NET Frameworks 1.0, 1.1, 2.0 (all came with VS2k5)

some more msvcXXX libraries I've found at dll-files

Simply the same composition like before :/

PS: Is the application compiled statically? To not need users to have VC Redist libraries?

PS2: Possibly this is caused by some kind of dependency we don't know about. Could you do something about it?


Link to post
  • 2 weeks later...
  • 1 year later...

Due to me being incredibly busy with other stuff, I decided to release the current version of AveDesk 2 as a "beta" for everyone.


Stuff Implemented

  • UI has been cleared up: using the XP font now everywhere, tooltips, etc
  • Proper lighting for the rotation effect
  • AvailableDesklets API (eg. for widgetdock)
  • Add-a-desklet dialog
  • bunch of new APIs
  • debug console [herd]

Implemented, but not working yet

  • Sublayers
  • Policies
  • stand-alone desklets

Bugs killed


- fixed a bug where rotated layers would not be fully rendered. [ave]


- fixed so-called "ghost desklets" bug. [ave]

- fixed bug with desklets not showing up when animation was enabled.[ave]

- fixed closebutton going behind the desklet bug [ave]


- newly installed fonts from AveInst-files will now be reconized by desklets: All desklets will be restarted automatically to make the fonts visible to GDI+. [ave]


- fixed threading issue in main rendering routine, making avedesk crash. [ave]

- hotkeys now finally work. [herd]

- tray icon now reappears properly when explorer.exe reloads. [herd]

- control panel will now be reactivated when it's visible but not the

front window. [ave]

- fixed threading issue with IDesklet::ObjectModel implementation. [herd]


- fixed problem with non-ascii languages not being able to input text in avedesk text controls (sendmessagew/ wm_syskeydown problem). [ave]






http://mpj.tomaatnet.nl/WidgetDock.rar (graphics are ripped)

use on own risk. etc yada yada.

The Links Are Dead Do You have Another link i can use?

Link to post

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now

  • Create New...