Jump to content

Universal UXTheme Patcher v2.1


flyakite

Recommended Posts

  • Replies 78
  • Created
  • Last Reply

Top Posters In This Topic

  • 3 months later...
  • 2 weeks later...

Sure, go ahead and stickie this. Sorry I haven't been on or around recently, but I have been very busy. I'm trying to catch up with e-mail now (about 300 of them), and hopefully I'll be online in the next week or so. Take care.

Alrighty, cool :D. -NC

Link to post
  • 1 month later...

hi, i am new here,

i greatly appreciate flyakite's work

recently, i reformatted my computer and (after i installed all those windows updates) i tried installing flyakiteOSX 3.5 - the tiger theme would not apply, i've read multiple forums and found out that my uxtheme was not patched... i tried the patcher in this post and would not avail

so after seeking around, i have found:

http://www.neowin.net/forum/index.php?showtopic=140707

the second post is the important one... seems maybe a recent windows update has increase data protection and prevented the patching... i used the replacer method that second post and got it to work

hope this may help other people facing the same problem

Link to post
  • 4 weeks later...

As of a few minutes ago, I've updated the version to 1.5. It basically just adds support for the most current uxtheme versions and fixes a minor internal bug.

hi,

I was wondering if this patcher, or if anyone knows of a uxtheme patch that supports the XP professional sp2 version 5.1.2600.2562? because without it can't 'mac-ify' my xp :( and this is the only promising patcher I can find

any help will be much appreciated, thank you

mac wanna be xxx

The problem isn't the XP version, the problem is the uxtheme.dll version. Go into WINDOWSsystem32 and find uxtheme.dll. Then check it's properties and look at the file version. That's what we need to know. However, my tool should work for every existing 32bit uxtheme version, so give it a try and see what happens.

Hey :) I was just wondering if there will ever be a 64bit Version of this wonderful tool. It would be so sad if you will never build something like that which u said in the first post :(

Hopefully sometime, but I'm not promising anything. The problem is 64bit is much different than 32bit and I originally never had a 64bit version to do testing on. However thanks to academic programs and licensing, I have a 64bit xp license and might be able to do some work on 64bit compatibiliity in the coming weeks. We'll see.

Link to post

Well, because I feel the need to tell someone, I am about 1/3 of the way finished with 64bit support. As of a couple of hours ago I have x64 loaded up in VMware, and have been doing hex comparisons on uxtheme files to find the right offsets to patch, and did a test to see if I could binary edit 64bit files from a 32 bit installer.

It turns out I can, and then I found out how to disable the 64bit system file redirection for 32bit apps (by default they access the 32bit folder SysWOW64, not system32).

So by the end of tomorrow I will probably have a new version supporting 64bit. If anyone wants to help me do some quick testing PM me and include your uxtheme version please. Thanks!

Link to post
hey fk,

I was wondering if there'd be any benefit to installing this updated UXTheme Patcher2.0 over the one that installs with FlyakiteOSX3.5?

Thanks in advance,

fc

Nope, it's simply a tool that makes it so you can use 3rd party visual styles. If those are already working from the FlyakiteOSX 3.5 patch, then you're good.

Link to post

Updated to v2.1 (fixed a few bugs I missed when adding 64bit compatibility), and figured out a way to do some things differently so that I could make the tool even smaller (66.5kb total now). Supports all uxtheme files (other than Vista) and takes about 1 second to patch.

I was wondering if there will be a new pack and if so what improvements/addons wil the pack contain?

Eventually, and I don't know. I haven't started work on it yet, but I will soon. My first priority is to release an updated version of FlyakiteXP (you can find info for it somewhere on the forum here, it's been quite awhile)

Link to post
  • 3 weeks later...
  • 1 month later...
Hi Fly,

I thin I've a uxtheme.dll version that cant be patched with the current patcher (6.0.2900.2845)

maybe it helps...

32-bit or 64-bit Windows? And this is with the most recent 2.1 patcher? Because I just checked the code and that version is in the installer for 32-bit.

Link to post
  • 3 weeks later...

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...