Jump to content

AveScripter bug report thread


Recommended Posts

when i inititate showcase-ave desk quits is really annoying

and when i try to save my theme it fails t odo so-and with 1.3 i have noticed that for some reason my theme is always resetting.

so i always have t ostart from scratch a theme does not last longer then 3 days on my machine it just resets

i have a centrino 1.8 laptop running xp pro

I double that report. The PC where it happens is also a laptop, RoverBook (non-mobile Intel Pentium 2,66 Ghz, 256 RAM, integrated 32MB Intel video controller, WinXP Home SP1).

But what happened today to my home AveScripter installation... It refuses to do any script actions (it flips, shows and hides layers but doesn't react a click). AveScripter version is I dunno what's wrong. I didn't install or uninstall anything (unless my brother did). I didn't change anything in dll, js, vbs or xml files. I was inteding to make a few configs today, but instead... I'm very confused... All other desklets (non-Scripter) work fine, hence it's not AveDesk. System scripting engine (which is probably used in AS) works allright too (tried on GUID Generator.vbs from Installeable Packages folder of AveDesk). Do you have a clue what's going on?

I'm very bored today, my Surge Protector suddenly turned off the power, having killed my work project I was planning to finish at home. I tried to dispel with help of AS programming, but it made me a new surprise.

[EDIT] Latest beta says no scripting engine... Ooops. Where could it vanish? What to do now?

Link to post
  • Replies 71
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Posted Images

ya... I added that feature in the BETA version to tell you the problem. No engine means that the mscript.ocx has been unregistered. You need to reregister it. I'm planning to make the scripter reregister it automatically if it can't be loaded.

I noticed that some softwares during the uninstall process will unregister the ocx. This is out of my control and BAD BAD uninstall software.

Link to post

Oh, thanks! That helped! Still can't understand what happened to my system. :( IE thinks he's 5.0 (when I actually have 6.sp1), Windows Genuine Check says my OS is stolen... Outlook doesn't reply the e-mails (mailto: links don't work either)... Something went terribly wrong after my last HDD died.

BTW, can AveInstaller do the shell commands after the files copied? Maybe make a simple aveinst?

Link to post

ya... AveInstaller can easly do it I think...But I still think I'll add it in to the code anyhow... Since it happens after you uninstall, it means that even after avescripter is installed it could be broken by someone's bad uninstall.

Link to post
This is actually system-behaviour, not AveDesk behaviour, so the desklet should just call the system wide function instead of round-tripping thru avedesk again.

#include <wininet.h>
#pragma comment(lib,"wininet.lib")

bool IsConnectedToInternet()
// post: true has been returned if there is an internetconnection, otherwise false has been returned
return InternetGetConnectedState(&dwConnectionType,0)==TRUE;

Sounds good for me and If this function can be called periodicaly so that if we are disconnedted and reconnected, we dont have to do "refresh data" to get the weather or RSS updated

Link to post

The XML default for the weather is 120 mins for 7 day forcast and 30 for today forcast. With the new code. If the internet is offline and the "Time" as expired it will try every minute to get the information. So once you go online it will get the information about 1 min later. While online or offline it will not get the information again till that time as expired (120 min or 30 mins) if the time expires while your offline, it will try to get the information every minute. But it will not trigger a connect. What it will do is check if the internet is on every minute, if its off then try again 1 minute later. Otherwise just get the information and reset the delay.

120 mins and 30 mins is the "Recommended" time from weather.com. This avoids too much traffic to their site.. Any more, and they can band your IP!

Link to post

Funny, the very same thing with unregistered msscript.ocx happened today to my laptop. For those, who can't understand what to do: just execute the following command line

regsvr32 msscript.ocx

and then restart the AveDesk - your widgets will get operable back.

BTW seems like the OnChange event for controls fires up even when we change the value from inside the script (not the user does it). So when I try to correct the user's input in the edit box, I get into infinite cycle.

Link to post
  • 1 month later...

All bugs are found while using the latest beta (xx.1.16)

Bug Description: Color Dialog results misinterpreted

When I show the color dialog with this.UI.PromptColor() and select some color there, it works, but seems like AveScripter misnterpretes the results (probably R and B bytes are confused while converting to HTML color string.)

See the screenshot attached, please. I shows the result of PromptColor() for Layer.SetColor (literally this.Layers(LayerName).SetColor(this.UI.PromptColor())).

Bug Description: Shadow is made out of the first introduced desklet layer (assumed to be a background) instead of actual desklet picture.

Items involved: Digital Clock for AveScripter

Steps to reproduce: Open Digital Clock and try to enable shadow for it. the resulting picture looks weird and doesn't correspond the real digits displayed. Obviously, the shadow is rendered with only the first layer an then stretched across the whole desklet.

Bug Description: Scripted desklets do not load their own alpha value

Items involved: Every AveScripted-powered desklet currently available (normal, hard-programmed ones work fine in this aspect)

Steps to reproduce:

1. Load any AveScripter config

2. Go to Desklet Properties dialog and set the Alpha value to non 255

3. Close the dialog with OK button. Note that alpha works now.

4. Exit AveDesk, forcing it to save the theme

5. Start AveDesk again and go to Desklet Properties dialog of selected AveScripter config. Note that Alpha became 255, and the desklet is opaque again.


Link to post

Bug description: All Avescripter widgets do not work at all, for any reason

Items involved: Any Avescripter based widget

Windows Version: XP Pro SP2

DirectX version: 9.0c

System specs: P4m 2.4 Ghz, 521k Ram, 30 gig HD

Graphics card & drivers version: Nvidia 64 MB Gforce4Go edition

Desklets running: AVES - Comics, Weather IV, Calender II, Converter, digital clock

Last thing i modified to Avedesk was the Curved bar widget for Sysstats, completely uninstalling and reinstalling did nothing.

Link to post

The reregistering of the script engine seems to be the common solution. For some reason, some software unregister it after and uninstall.

The next version of avedesk will reregister it automaticially if can find the engine file.

Link to post
Maybe try the solution from post#57 this thread, http://www.aqua-soft.org/board/showpost.ph...56&postcount=57

What does it mean 'do not work at all'? They load with empty image? Or do not produce any actions? Telll more of your problem.

That was it!

Sorry i wasn't more specific, but heres what was happening for future reference:

I figured it was because I had attempted to install Curved top bar through the .xml file provided. What was happening or the bug, was that no scripters would respond to any kind of action. Also things like calender II would show a 0 for all numerical entries.

Link to post
  • 1 month later...

Sorry, pcm, I know this is bad bug report, but I'm having troubles of known sort again: AveDesk (with 2 or 3 AveScripter widgets and 2 instances of one hard-coded desklet) suddenly quits when I call ShowCase (F11 in my config :)). Still investigating why. Ok, we found out everything, sad that we'll have to wait until next AveDesk release :(

Link to post
  • 3 months later...
win xp sp2

direct x9c

Calendar only showing 00, can'y link it to tha tasks file

weather with funky behaviour

Re-install everything with the latest packages.

add calendar...

Sounds like the MSScript engine is not installed. If you use the latest lastest beta, it fixes all this. (It selfs reregisters the MSMscript engine)

Link to post
  • 1 month later...

When I call IsConnectedToInternet I get "Catastrophic failure" error on that line (maybe it is misspelled here, my system prompts in Russian).

No matter why, I cannot check connection now. If I try to get XML data from the web when there's no connection, will I have an exception thrown? I need something to cancel the transaction.

Link to post

I'll double check this bug in the following weeks.

But if your using the beta version, it will not download xml from the web unless there is an internet connection.

I think from memory, if you force a download of xml it will try to establish a connection. But no exception should be triggered.

Link to post

OK, pcm. I solved this all. This was, as you might guess, for Unit Converter Plus (the currency updates). My solution was to ignore the empty value returned by XML.GetValue() and not to save it into units.xml.

And "Catastrophic failure" is ussually thrown when operating with OLE (COM-to-JavaScript introduced objects in this case).

Link to post

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now

  • Create New...