Jump to content

AveScripter bug report thread


Unbeliever

Recommended Posts

  • Replies 71
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Posted Images

Bug description: Desklet disappears in Showcase - doesn't keep transparency settings

Items involved: Weather desklet

Windows Version: Windows XP Pro SP2

DirectX version: 9.0c

System specs:AMD Athlon 64 3000+, 1.5 GB of DDR RAM

Graphics card & drivers version: Ati Radeon 9600 with 128mb of RAM, Catalyst 5.10

Desklets running: PIDL, Translator, AveScriper - Clock, Weather, Calendar and PictureViewer

Steps to reproduce:

1. Create a AveScriper - Weather desklet

2. Set to Showcase

3. Set transparency to 255

4. Restart AveDesk

5. Press F8 for Showcase

6. Weather Desklet appears for half a second and then disappears (it's still loaded !)

7. Check settings and see that transparency got set to 240

Other than that AveScripter is just awesome - Thanks !

bM3w

Link to post
What do you mean the date screws up? Are you referring to the graphics? or the date number... Your screen shoot looks like the entire graphic goes nuts.

Well if the entire graphic is the month's day on the left, then yes. Once you jump back/forward a month then go back to current month, the day goes back to 1.

Link to post
Bug description: Desklet disappears in Showcase - doesn't keep transparency settings

Items involved: Weather desklet

Windows Version: Windows XP Pro SP2

DirectX version: 9.0c

System specs:AMD Athlon 64 3000+, 1.5 GB of DDR RAM

Graphics card & drivers version: Ati Radeon 9600 with 128mb of RAM, Catalyst 5.10

Desklets running: PIDL, Translator, AveScriper - Clock, Weather, Calendar and PictureViewer

Steps to reproduce:

1. Create a AveScriper - Weather desklet

2. Set to Showcase

3. Set transparency to 255

4. Restart AveDesk

5. Press F8 for Showcase

6. Weather Desklet appears for half a second and then disappears (it's still loaded !)

7. Check settings and see that transparency got set to 240

Other than that AveScripter is just awesome - Thanks !

bM3w

That's an AveDesk problem. I get it with other desklets too.. Sometimes the translator desklet doesn't even show up at all and sometimes it draws itself and you can't click it. the bug is worse if you got multimonitor :S

Bug Andreas to fix it :P

Link to post

Bug description: can't get weather, or RSS working. for d-weather, i can't seem to change the City or Temperature no matter what, i type City or zipcode and press enter, nothing happens. for RSS feed, i change the URL and press done. it doesn't change or go back to the RSS feeds but stays in window where you enter URL.

AveScripter Version: 1.0.0.1

Windows Version:XPSP1

DirectX version:9c

System specs: p4 2.8c

Desklets running:ave scripter, weather, rss

okay i dunno what is going on. can't seem to get avescripter working for some reason.

Link to post
Bug description: can't get weather, or RSS working. for d-weather, i can't seem to change the City or Temperature no matter what, i type City or zipcode and press enter, nothing happens. for RSS feed, i change the URL and press done. it doesn't change or go back to the RSS feeds but stays in window where you enter URL.

AveScripter Version: 1.0.0.1

Windows Version:XPSP1

DirectX version:9c

System specs: p4 2.8c

Desklets running:ave scripter, weather, rss

okay i dunno what is going on. can't seem to get avescripter working for some reason.

Can you download and try the latest version 1.0.1.0.. The communication protocol has been completly redone.

Link to post

In the latest versino of avescripter (1.0.1.0) the rss news feed doesnt display headlines on startup (occasionally), and the d-weather desklet wont display the main weather icon on startup (always).

i went back to the original avescripter version to check .. and dont experience these bugs with it ..

Link to post
In the latest versino of avescripter (1.0.1.0) the rss news feed doesnt display headlines on startup (occasionally), and the d-weather desklet wont display the main weather icon on startup (always).

i went back to the original avescripter version to check .. and dont experience these bugs with it ..

I don't use the RSS module, but I'm experiencing the same thing with D-weather since I upgraded to 1.0.1 Avescripter...I have to re-enter my city name every time I restart.

Link to post

Bug description: Annoying "Connect" pop-ups!!!

Items involved: Weather desklet at the moment and in future all Internet based desklets!!!

Windows Version: Windows XP Pro SP2

DirectX version: 9.0c

System specs:Pentium 4 3.4ghz, 1024mb of unknown RAM ;)

Graphics card & drivers version: GrForce 6800 256mb of RAM, Forceware 81.95 WHQL

Desklets running: PIDL, AveScriper - Weather and Calendar

Steps to reproduce:

1. Create a AveScriper - Weather desklet

2. Save the AveTheme in control panel

3. EXIT AveDesk and ReStart AveDesk OR Restart Windows OR Log-Off Windows & Log-In

4. BANG! Connect Connect Connect!!!

Special notes: This is the most annoying thing I encounter in almost all Internet based desklets and I assume i am not the only Dial-Up user getting annoyed by it. If internet or network is NOT connected (if there is NO ip address present), AveScripter should block connection request of Internet based desklets (such as weather, mail-check, horoscope, RSS etc etc). If a user manually clicks "Update" or "Refresh" then AveScripter should allow the normal procedure. In an event where the connection is detected as "OFF" then, weather should show previous weather. Sometimes user manually clicks refresh and they're asked to connect and if they choose "cancel" button, desklets should show previous state NOT (n/a or empty or XXX error messages)

Imagine when there are desklets asking for connection every 10 mins or 20 min (RSS or Mail-Check desklets) these things will bug users like anything (Connect dilog every 10 min or 20 min)

On the other hand, I always thought its better for AndreasV to add this kind of function in main AveDesk engine. Now this is because desklets makers are plenty and there can be so many variables when it comes to Scripting Engines (SysStat, AveScripter, etc etc) and stand-alone desklets without scripting engines tring connections all on their own.

Link to post

Noted... and on my top list to fix. Should be a easy enough change to do.

I know that I have already put code that will show the previous state if the desklet can't connect, so it just a matter of adding abit more to check for connection state.

Thanks for the feedback. If your ok with Betas, you might want to join in the beta section and test the feature out when it will be done.. Like I said, I don't think it would be hard to implement and for sure important. I'm just spoiled and always have internet. :P

Link to post

On the other hand, I always thought its better for AndreasV to add this kind of function in main AveDesk engine. Now this is because desklets makers are plenty and there can be so many variables when it comes to Scripting Engines (SysStat, AveScripter, etc etc) and stand-alone desklets without scripting engines tring connections all on their own.

This is actually system-behaviour, not AveDesk behaviour, so the desklet should just call the system wide function instead of round-tripping thru avedesk again.

#include <wininet.h>

#pragma comment(lib,"wininet.lib")



bool IsConnectedToInternet()

{

// post: true has been returned if there is an internetconnection, otherwise false has been returned

DWORD dwConnectionType = INTERNET_CONNECTION_MODEM | INTERNET_CONNECTION_LAN | INTERNET_CONNECTION_PROXY;

return InternetGetConnectedState(&dwConnectionType,0)==TRUE;

}

Link to post

Bug description: D-Weather location is not being retained

Items involved: AveScripter D-Weather Desklet

Windows Version: WinXP Pro w/SP2

DirectX version: 9.0c

System specs: Intel P4 3GHz 2GB of RAM

Graphics card & drivers version: NVIDIA GeForce 6800 GT

Desklets running: AveScripter (D-Weather); AveScipter (Calendar); iTunesDesklet; 4 PidlShortcuts (Recycle Bin, DVD-RW Drive, Folder, Network Storage)

Steps to reproduce: Set zip code (City,State) .... When computer is restarted after being shutdown, the location information is missing and needs to be re-entered

Special notes: This behaviour does not happen with the AveScripter supplied weather desklet.

Link to post

Bug description: Changing a side's dimensions offplaces controls

Items involved: AveScripter Engine

Windows Version:-

DirectX version: -

System specs: -

Graphics card & drivers version:-

Desklets running: -

Steps to reproduce: Do

  this.sides(0).width = 100;

this.sides(0).height = 100;

And notice only controls gets offplaced and scaled, not the layers. (Which makes sense somewhat). I can fix it by replacing and resizing the controls, but it flickers.

Link to post

i dont know if this was the old version and forgive me for not giving an example but i think u will know what im talking about. on the itunes desklet when u press the "pause button" it really stops it and all i did to change it was change stop to play. not really a bug, but annoying. again, i dont even know if this has already been fixed, just a little to lazy to read all the bug reports.

Link to post
This is actually system-behaviour, not AveDesk behaviour, so the desklet should just call the system wide function instead of round-tripping thru avedesk again.

#include <wininet.h>
#pragma comment(lib,"wininet.lib")

bool IsConnectedToInternet()
{
// post: true has been returned if there is an internetconnection, otherwise false has been returned
DWORD dwConnectionType = INTERNET_CONNECTION_MODEM | INTERNET_CONNECTION_LAN | INTERNET_CONNECTION_PROXY;
return InternetGetConnectedState(&dwConnectionType,0)==TRUE;
}

Oh... I was outta town (now back). All desklets uses AveDesk to call system... the idea is to block such system call (which eventually leads to pop-ups). It may be possible that PCM may fix this by your code, but there are other developers who will have to put this code of yours in all desklets they made. Some of them don't update their desklets as they have busy life while others may not know this code (new future desklet makers) and besides, I don't like the idea that all desklet developers should add this same code. Think about it, Its always better to update AveDesk with this function once rather then desklets developers updating and fixing all their desklets one by one. AveDesk controlling this desklet behaviour is not a bad idea from my perspective.

Anyhow, You can ofcourse ignore poor me ;) I mean your stuff is way too kewl in any ways (won't really affect your current image :D ) Its just that I may have to report this bug to so many new developers :D

I remember the first time I reported this same bug to you AndreasVJ... It was like your Mail-Check desklet for Y Z Dock and you fixed and PM'ed me :) may be year or two back :D "Lovely Work" ;)

OXTIE, If you sign up for the beta, you'll be able to download the latest version that checks if the internet is active.

Sign-Up? where'z the link :D you know I would love to :D Grab me a pm (just in case... you never know.... I may lurk around somewhere else instead)

ok found the beta section on this forum ;) I was going like Search --> "Beta Section" then, Root DIR of this forum looking one by one logically for "Beta Section" (yeah I'm stupid sometimes).

hmmm... can't find beta section on that avedesk site forum... under downloads I see one fix (not sure if this is the one)

Link to post
i dont know if this was the old version and forgive me for not giving an example but i think u will know what im talking about. on the itunes desklet when u press the "pause button" it really stops it and all i did to change it was change stop to play. not really a bug, but annoying. again, i dont even know if this has already been fixed, just a little to lazy to read all the bug reports.

The last ITunes / Scripter pacakage I fixed the Pause.

Oxtie, I'll PM for beta.

Link to post

when i inititate showcase-ave desk quits is really annoying

and when i try to save my theme it fails t odo so-and with 1.3 i have noticed that for some reason my theme is always resetting.

so i always have t ostart from scratch a theme does not last longer then 3 days on my machine it just resets

i have a centrino 1.8 laptop running xp pro

Link to post

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...