Jump to content

[release] Sinapse v0.1


siwu

Recommended Posts

Yeah, when I decrease my resolution, it works much better.

As for my earlier problem, sometimes this program works and sometimes it doesn't :(. .Net 2.0, or something, has slowed my computer down a heck of a lot, though.

When this is working, and at the proper speed, this is a great program. I know how hard it is to code software for so many different video cards, and I can tell you've done great work.

Thanks!

-NC

Link to post
  • Replies 144
  • Created
  • Last Reply

Top Posters In This Topic

Siwu, this isn't really my area of expertise, but maybe there's some way to refine your algorithms so that the performance decrease at higher resolutions isn't as dramatic without having to "fake" a 1024 device and expand it out to higher resolutions?

The problem with really large resolutions is that the 3D card don't handle them very well, combined with the fact that you have 1:1 textures, the result is what you experience right now: slow. The workaround would be to allow the card to render less pixels, hence increase the performance. I'm sure you don't play games at 1920x1200 :)

Link to post

The app runs great on my laptop, as Autumnmist stated, "smooth as butter!" The only issue I have is that most of the times I hibernate my laptop (which I do quite frequently), Sinapse crashes when I bring it back up again. Regardless of that error, I will say that this is the first Expose clone that I find can really be added to my normal set of apps and used regularly. Pretty stable, and quite attractive. I'll post the error log next time it crashes.

System information:

-------------------

Machine Name: *****

OS Version: Microsoft Windows NT 5.1.2600.0 Service Pack 2

Manufacturer: Dell Computer Corporation

Model: Inspiron 5150

System Type: X86-based PC

Total RAM: 511MB

Processors Count: 2

-Mobile Intel® Pentium® 4 CPU 3.20GHz at 3189Mhz

-Mobile Intel® Pentium® 4 CPU 3.20GHz at 3189Mhz

Bios: DELL - 27d4071e

Current Date/Time: 1/13/2005 1:38:28 PM

TimeZone: ****

Graphic information:

--------------------

Device: 0

Name: GeForce FX Go5200

GDI Name: .DISPLAY1

Display Mode: 1024x768 at 60Hz X8R8G8B8

ID: 324

Revision: 161

SubSystem ID: 15f1028

Vendor ID: 10de

WHQL Level: 0

GUID: d7b71e3e-4064-11cf-ce69-552100c2cb35

Driver: nv4_disp.dll

Driver Version: 6.14.10.6742

MultiSample Types: None, NonMaskable, TwoSamples, FourSamples,

Max Texture Size: 4096x4096

Max MultiTexturing: 8

Non ^2 Textures: True

Assembly information:

---------------------

Application Domain: Sinapse.exe

Application Path: C:Program FilesSinapse_v0.1

Application Codebase: file:///C:/Program Files/Sinapse_v0.1/Sinapse.exe

Assembly Full Name: Sinapse, Version=1.0.1832.23750, Culture=neutral, PublicKeyToken=null

Assembly Version: 1.0.1832.23750

Exception information:

----------------------

Exception Type: Microsoft.DirectX.Direct3D.InvalidCallException

Exception Source: Microsoft.DirectX.Direct3D

Exception Message: Error in the application.

Exception Target Site: Reset

Stack Trace information:

------------------------

Microsoft.DirectX.Direct3D.Device.Reset

Sinapse.Core.SinapseWindow.AttempRecovery

Sinapse.Core.SinapseWindow.Render

Sinapse.Core.SinapseCore.Render

Sinapse.SinapseMain.Main

Link to post
Guest Jesus Franco

Thank god .net framework is fully backwords compatible with all applications requiring .net framework 2.

Thank you very much for this very nice application Siwu.

I do have one question however, whats up with this app being released? And what will happen to Expire?

Thanks

Link to post

Sorry to be the bearer of bad news but, another bug. I think this is the same thing as hexydes and edotkyle have. I get the same window as hexydes posted with the following error report. It looks to me like a fault in one of the DLLs.

System information:

-------------------

Machine Name: JAMES

OS Version: Microsoft Windows NT 5.1.2600.0

Manufacturer: KT266_

Model: AWRDACPI

System Type: X86-based PC

Total RAM: 255MB

Processors Count: 1

-AMD Duron processor at 999Mhz

Bios: KT266 - 42302e31

Current Date/Time: 16/01/2005 23:08:49

TimeZone: (GMT) Greenwich Mean Time : Dublin, Edinburgh, Lisbon, London

Graphic information:

--------------------

Device: 0

Name: ATI Technologies Inc. RAGE 128 PRO AGP 4X TMDS

GDI Name: .DISPLAY1

Display Mode: 1280x1024 at 60Hz X8R8G8B8

ID: 5046

Revision: 0

SubSystem ID: 81002

Vendor ID: 1002

WHQL Level: 0

GUID: d7b71ee2-1306-11cf-de73-0820a5c2c835

Driver: ati2draa.dll

Driver Version: 5.10.0.108

MultiSample Types: None,

Max Texture Size: 1024x1024

Max MultiTexturing: 2

Non ^2 Textures: False

Assembly information:

---------------------

Application Domain: Sinapse.exe

Application Path: D:DocumentsInfinityMy DownloadsApplicationsSinapse

Application Codebase: file:///D:/Documents/Infinity/My Downloads/Applications/Sinapse/Sinapse.exe

Assembly Full Name: Sinapse, Version=1.0.1832.23750, Culture=neutral, PublicKeyToken=null

Assembly Version: 1.0.1832.23750

Exception information:

----------------------

Exception Type: System.DllNotFoundException

Exception Source: Sinapse.Core

Exception Message: Unable to load DLL 'Sinapse.Hook.dll'.

Exception Target Site: UnregisterKey

Stack Trace information:

------------------------

Sinapse.Core.SinapseHooksForm.UnregisterKey

Sinapse.Core.SinapseHooksForm.UnregisterHotKey

Sinapse.Core.Configuration.set_ExposeKey

Sinapse.Core.SinapseCore.LoadConfig

Sinapse.Core.SinapseCore..ctor

Sinapse.Core.SinapseCore.GetInstance

Sinapse.SinapseMain.Main

Link to post

I get the out of video memory issue as well. Fatal Exception , etc. Wont start.

I have 1.5GB system ram and 128 mb vid ram on an ATI Radeon 9600xt running @ 1600x1200x32

I tried lowering the res and it didnt help tho.

Exception information:

----------------------

Exception Type: Microsoft.DirectX.Direct3D.OutOfVideoMemoryException

Exception Source: Microsoft.DirectX.Direct3D

Exception Message: Error in the application.

Exception Target Site: CreateSurfaceFromBitmap

-meat

Link to post

I also am experiencing this Dll not found exception....Have posted error for reference....Really frustrating too coz all of the posts here sound fantastic...

System information:

-------------------

Machine Name: CODERED

OS Version: Microsoft Windows NT 5.1.2600.0

Manufacturer: TOSHIBA

Model: TE2100

System Type: X86-based PC

Total RAM: 766MB

Processors Count: 1

-Mobile Intel® Pentium® 4 - M CPU 1.80GHz at 1794Mhz

Bios: TOSHIB - 970814

Current Date/Time: 17/01/2005 5:43:45 PM

TimeZone: (GMT+10:00) Canberra, Melbourne, Sydney

Graphic information:

--------------------

Device: 0

Name: NVIDIA GeForce4 420 Go (Toshiba)

GDI Name: .DISPLAY1

Display Mode: 1024x768 at 60Hz X8R8G8B8

ID: 175

Revision: 163

SubSystem ID: 11179

Vendor ID: 10de

WHQL Level: 0

GUID: d7b71e3e-4235-11cf-2663-0b2002c2cb35

Driver: nv4_disp.dll

Driver Version: 6.14.10.4591

MultiSample Types: None, NonMaskable,

Max Texture Size: 2048x2048

Max MultiTexturing: 2

Non ^2 Textures: True

Assembly information:

---------------------

Application Domain: Sinapse.exe

Application Path: C:Documents and SettingsNaveenMy DocumentsDownloadsSinapse_v0.1

Application Codebase: file:///C:/Documents and Settings/Naveen/My Documents/Downloads/Sinapse_v0.1/Sinapse.exe

Assembly Full Name: Sinapse, Version=1.0.1832.23750, Culture=neutral, PublicKeyToken=null

Assembly Version: 1.0.1832.23750

Exception information:

----------------------

Exception Type: System.DllNotFoundException

Exception Source: Sinapse.Core

Exception Message: Unable to load DLL 'Sinapse.Hook.dll'.

Exception Target Site: UnregisterKey

Stack Trace information:

------------------------

Sinapse.Core.SinapseHooksForm.UnregisterKey

Sinapse.Core.SinapseHooksForm.UnregisterHotKey

Sinapse.Core.Configuration.set_ExposeKey

Sinapse.Core.SinapseCore.LoadConfig

Sinapse.Core.SinapseCore..ctor

Sinapse.Core.SinapseCore.GetInstance

Sinapse.SinapseMain.Main

Link to post

I have the following setup:

Operating System System Model

Windows XP Professional, Service Pack 2 No details available

Processor a Main Circuit Board

2150 megahertz AMD Pentium III

128 kilobyte primary memory cache

256 kilobyte secondary memory cache Board: MICRO-STAR INTERNATIONAL CO., LTD MS-6570

Bus Clock: 166 megahertz

BIOS: Phoenix Technologies, LTD 6.00 PG 01/16/2003

Drives Memory Modules

347.54 Gigabytes Usable Hard Drive Capacity

195.38 Gigabytes Hard Drive Free Space

AXV CD/DVD-ROM 2.2a [CD-ROM drive]

DVD-ROM [CD-ROM drive]

TDK CDRW401240B [CD-ROM drive]

3.5" format removeable media [Floppy drive]

Maxtor 6B250R0 (137.44 GB) [Hard drive] -- drive 0

Maxtor 6Y120P0 (122.94 GB) [Hard drive] -- drive 1 1024 Megabytes Installed Memory

512 Megabyte Module Size - 2 Installed

One Memory Socket is Empty

Local Drive Volumes

c: (on drive 0) 10.49 GB 4.35 GB free

d: (on drive 0) 104.86 GB 51.22 GB free

e: (on drive 0) 52.43 GB 44.14 GB free

f: (on drive 0) 52.43 GB 27.07 GB free

g: (on drive 0) 2.10 GB 2.07 GB free

p: (on drive 0) 2.10 GB 479 MB free

r: (on drive N) 210 MB 122 MB free

z: (on drive 1) 122.94 GB 65.92 GB free

Network Drives

Controllers Printers

NVIDIA NForce MCP2 IDE Controller

Primary IDE Channel [Controller]

Secondary IDE Channel [Controller]

Adobe PDF Converter on My Documents*.pdf

HP DeskJet 930C/932C/935C on USB001

Display

NVIDIA GeForce4 Ti 4200 (Omega 1.6177) (Q) [Display adapter]

Bus Adapters Multimedia

A347SCSI SCSI Controller Creative Game Port

Creative SB Audigy

Communications Other Devices

NVIDIA nForce MCP Networking Controller

NVIDIA nForce MCP Networking Controller - Packet Scheduler Miniport

Network Card MAC Address: 00:10:DC:99:AB:FF OHCI Compliant IEEE 1394 Host Controller

VIA OHCI Compliant IEEE 1394 Host Controller

Logitech Cordless USB Mouse [Joystick]

Generic USB Hub

Standard Enhanced PCI to USB Host Controller

Standard OpenHCD USB Host Controller

Standard OpenHCD USB Host Controller

USB Printing Support

USB Root Hub

USB Root Hub

USB Root Hub

I installed the .NET Beta. I un-rar'd sinapse and clicked on Sinapse.exe. A SinapseConfig.xml was created. What do I do now?

Link to post

Fantastic app, runs smooth even when my laptop is running in 600MHz power saving mode!

Only problem I have is my desktop picture is mostly solid white, and the window images don't show up on it when I press expose - they are there because the mouse pointer changes when I move over them, I just can't see the images!

Link to post

As far as I can see, no config file is created upon execution :( Good to know im not the only one having this problem, but really eager to try this out. Any other ideas?

Have also uninstalled .NET framework and reinstalled....with rebooted inbetween..no luck either.

Link to post
^^ you're missing this dll 'Sinapse.Hook.dll' did you not extract it out of the ZIP or have it i you're sinapse directory?

-bolero

I have checked, I certainly have Sinapse.Hook.dll in the same (extracted) folder as the app and all other files from the RAR.

And did you set up Sinapse the first time while it was in one location on your computer, then move the folder to another? Try deleting the config file and rerunning Sinapse.

I haven't touched anything that was in the the RAR file apart from the App when I launched it.

:S

[edit] hexydes, my hardware acceleration is fully turned on and still it goes cap-ut :( [/edit]

Link to post

So then siwu, where are you going next with this excellent piece of software? Obviously there seems to be some 'niggles' to be worked out on some peoples systems. Personally I can not fault this early release of the software (the only problem I had was the font issue). I guess future releases will allow us to customize the look, colour and typeface used in the 'Sinapsed' windows?

Cheers for this great app!:D

(actually, just thinking a little bit further, would be brilliant if you could integrate something like 'AveFocus' to one of the hotspot corners to do its funky thing too! ;) (although, I seem to recall avefocus is redundant in the 1.2 release when it shows up)

Link to post

I can't quite tell you exactly *what* the problem was, other than the error log said out of video memory execption, but after killing yz shadow, toolbar, windowfx and windowblinds, it finallly loaded and worled fine. Then I killed sinapse, loaded yztoolbar, then started up sinapse again. I tried the same thing for each app and never had a problem loading up sinapse. So I dont know what the problem was. Since then, I have added sinapse to WB and Win FX and YZ Shadow's exclusion lists.

Hope it helps someone!

Not to detract from Sinapses glory, but you all might want to check out Winplosion. its not free but its a really REALLY slick expose type prog thats slicker than owl poop :)

Meat

Link to post

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...