Jump to content

[help] Weather Config Not Obtaining Data


mimeryme

Recommended Posts

I created this thread to pool information, in the hopes of finding a solution to a problem which plagues a minority of users.

The problem is that the weather configs available for SysStats do not seem to fetch the data. Instead of displaying the temperature value and the weather icon, we are instead shown '%s' and no icon whatsoever. (We have edited configs to work as it should; image paths, zipcode, etc have been edited according to instructions and advice provided on A-S.)

If you are part of this minority, please post any relevant information which may help solve the problem. Things such as internet connection, shell used, SysStats host program installation path (e.g. AveDesk install) and method, and other possibly pertinent items. (Since, I probably will miss some myself, I'll update my entry as others post data as well.)

Connection: Cable modem - Toshiba with D-Link router

Shell: BB4Win

OS: Windows XP Pro w/ sp1 - updated w/ all Critical updates

Firewall: KerioPF 2.1.5

Host path: d:\utilities\AveDesk\ - fresh zip install

SysStats path: \Docklets\SysStats

XMLmeter's URL: http://xoap.weather.com/weather/local/11208?cc=*&unit=e

Other: I've tried some troubleshooting.

  • Seeing if it works with ObjectDock. (no)
  • Moving SysStats from \Docklets to \Desklets.
  • Verifying Weather Docklet works.
  • Verifing XMLmeter's URL works.
  • Loading AveDesk only with a SysStats weather config.
  • Using zipcode or USNYXXXX
  • Turned off KerioPF.
  • Removed AveDesk from Kerio's safelist and checked to see if it tries to connect when using a weather config. (it doesn't)

Link to post

Hi,

1.

Verify that you have msxml4.dll in your Windows\System32 folder. This has been

said a few times on this board so use the search feature for its whereabouts.

2.

Verify that you can ping aqua soft or any other web page from the command line.

In that case you won't need 1.

hth

Link to post
Originally posted by NilColor@Aug 3 2004, 03:45 PM

I have this problem too

i have msxml4.dll

can ping aqua-soft.org

!! can't ping xoap.weather.com !! but http://xoap.weather.com/weather/local/11208?cc=*&unit=e working in browser... :wacko:

And? what i must to do?

XP-Pro SP1, LAN inet (don't know details... i'm not admin)

/edit

But Weather docklet for OB (not via SysStat) working good...

<{POST_SNAPBACK}>

Same here mate.I even mentioned this to judge but he was 'idle' at that time and didn't reply. :(

Link to post
Originally posted by judge@Aug 3 2004, 06:02 PM

OK. I just tried Neowin's RSS feed and get the same result as you all do with weather.com. So I might stand a chance of sorting this out now.

Caio - Judge

<{POST_SNAPBACK}>

Hope it's will be soon :naughty: But don't hurry. Well job can't be done quickly :smartass:

Link to post

I still have the issue where the background image of the config won't even load w/ the newer Meters plugin. I also tried using Explorer as my shell w/ the original Meters plugin and the latest one. Oh well.

If it works for everyone else who had a problem, it must be just on my end. Good to see it works for a few more now though.

Link to post

I've since tried updating to sp2 on top of my current install, but the problem was still present. I then formatted and installed a slipstreamed sp2 update and all is well.

The format probably cleaned up whatever it was that prevented the meter from updating correctly.

Thanks for all your help judge.

Link to post
  • 2 months later...

judge: that shockwave flash file fixed it.

you're the man!

(after fricken 4 hours editing .ini files left right and centre and it turns out NOT to be that or my (limited/lack of) knowledge of AveDesk! - only been using it 24 hours :)

bloody shockfile... grr.

those who made weather small, weather medium, weather big, weather mini -- it all looks good now with numbers on them, i was starting to see "%s" even when i wasn't looking at my computer screen)

gg.

Link to post
  • 2 months later...
  • 2 months later...

oh thank the lord indeed I googled into this page, I had been wrestling with this problem for weeks since it went down at about the same time as everyone else's. anyhow, that spl file fixed it and I am extremely grateful to judge - good lord I just might donate lol.

sunny and 57 here :)

Link to post

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×
×
  • Create New...