Jump to content
Aqua-Soft Forums
Sign in to follow this  
localhost

Plugin - Global Multimedia Keys

Recommended Posts

If you have a multimedia keyboard with Play, Stop, etc. buttons, you've probably noticed that those keys only work if the iTunes window is the active window.

this plugin fixes it :D

You should put it in C:\Program Files\iTunes\Plug-Ins :)

mmKeys.dll

Share this post


Link to post

Thanx man! (Y)

Great to finally be able to skip songs etc without having to make iTunes the active window.

Just one problem. The volume up-,down- and mute-buttons do not work. I use one of those cordless ergonomical keyboards from Logitech.

Share this post


Link to post

no problem ;)

what do you mean "they do not work"?

they should change the system volume when the iTunes window is not active, and change the iTunes volume when the iTunes window is active. is that what it is doing?

in the next version i'll try to make the volume keys to always change the system volume and not the iTunes one.

Share this post


Link to post

*heropsychodreamer

i'm assuming that you have the iTouch software (for your logi- keybord) installed right? Well if so you don't need that plugin for iTunes to make your keyboard work properly..I had to do the same for Qcd back when i used that app:

- go to your iTouch directory ( x:\Program Files\Logitech\iTouch) and open the file called players.ini

this is a list of all the media software that the logitech iTouch key's will work with notice that iTunes isn't listed (since it's new an all and logitech hasn't released new drivers) but no matter... all you need to do is Add this line in:

iTunes=wac,iTunes.exe,iTunes,xxx,xxx,X,C,V,Z,B,0,1,iTunes

then close iTouch and restart it. (task manager, or systray if you have it running in there)

put that line in the day i downloaded iTunes and its worked like a charm ever since (without having to have iTunes selected)

that should help ya out alot..

later

neXus

Share this post


Link to post

yeah...I have a Multimedia Keyboard that came with my Gateway Computer and this .dll doesn't seem to work either. Nice work though...maybe I can figure it out...

Share this post


Link to post

this should work with every standard multimedia keyboard. you just must first install the drivers of the keyboard of course, my plugin doesn't replace the driver.

Share this post


Link to post

Hey, plugin sometimes doesn't work if you put it in x:\program files\itunes\plugins

Instead, try to put it into:

x:\Documents and Settings\USERNAME\Application Data\Apple Computer\iTunes\iTunes Plug-ins\

and, on a safe side, here:

x:\Documents and Settings\All users\Application Data\Apple Computer\iTunes\iTunes Plug-ins\

And then it MUST work (possibly w/o keybord drivers, as in my case with Windrover USB kbd.)

But if NOT try to install WhiteCap vis. plugin first (see aquasoft news for link) - it will create correct folders under 'documents and settings' - and then try my methods above.

Good luck. BTW, nice plug! :)

Share this post


Link to post

hey localhost excellent idea for plugin, however its not working for me. I have an hp machine with hp multimedia keyboard. I do have the latest drivers and it works with all other progs, but iTunes. I still have to have it as active window. :(

i tried Minsky's way, still doesnt work. Why isnt it working, are there others out there like me.

Share this post


Link to post

Mmmm odd. The old plugin 0.65 worked nativly with hotkeys. 0.66 broke and i downloaded this dll which yesterday worked. However today it has stopped working :-/ I have not changed any settings

Share this post


Link to post
Mmmm odd. The old plugin 0.65 worked nativly with hotkeys. 0.66 broke and i downloaded this dll which yesterday worked. However today it has stopped working :-/ I have not changed any settings

Turn off multimedia key-support in mplugin and restart iTunes

Share this post


Link to post

Never had this trouble with iTunes. Ok I did the first time I used the media keys in MPlugin. Then I changed the mode to 2 and it worked sweetly.

Right up to when my Logitech keyboard died the other day.:( The model's the wireless with the nice volume dial on it. But it was a pair set with an MX700 mouse. And I hadn't upgraded any drivers. The iTouch version's 2.2.

Might want to investigate that, localhost. Regardless I'll have to get that new board.

Share this post


Link to post

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×
×
  • Create New...