Sign in to follow this  
Followers 0

Xwdock 2.0.0.0 - Help & Support

318 posts in this topic

Hi.

Please, ask your questions and problems with XWDock 2.0.0.0 here.

Some information about "how to":

1. Hold on the separator and move mouse to resize the dock, or hold on Shift to move the dock to another edge of the screen

2. Click on icon to run an application or activate the old one, or hold on Ctrl to run the copy of the application

3. Use drag&drop as much as possible. Drop icon (.png, .ico...) on any of dock's icons to setup a new one. Or drop any file onto dock's icons to run, open, copy and move it inside.

4. Now, when you drop Recycler Bin, empty it to setup an icon for the empty state, and fill in it to the full state.

5. Place your OD Docklets to Docklets\ folder, XWD 2.0 Plugins into Plugins\ one.

0

Share this post


Link to post
Share on other sites

everything looks like it's working out great so far. :)

Just one problem: I can't seem to get Matonga's stack docklet (2.0) to work. I'm putting it into the Docklets folder, but it's not showing up in the plugins menu? other OD docklets seem to work, just not this one.

0

Share this post


Link to post
Share on other sites

everything looks like it's working out great so far. :)

Just one problem: I can't seem to get Matonga's stack docklet (2.0) to work. I'm putting it into the Docklets folder, but it's not showing up in the plugins menu? other OD docklets seem to work, just not this one.

You should look at it carefully, cause this docklet requires StackLib.dll, for example.

0

Share this post


Link to post
Share on other sites

You should look at it carefully, cause this docklet requires StackLib.dll, for example.

ah of course, silly me.
0

Share this post


Link to post
Share on other sites

It's working hilarious. All the functions those implemented working without problem.

Thanks BOBAH13, that's a great comeback :)

0

Share this post


Link to post
Share on other sites

Hm. I tried to make a theme, at it looks like 2d-background-right-bottom doesn't work like it should. when I try to make a theme where the size of the top piece and the size of the bottom piece are different, I get a strange glitch at the bottom right corner.

Also, I notice that you're telling the middle pieces to tile vertically, but it would work better if it was stretched.

here's an image showing both problems:
/>http://img37.imagefra.me/img/img37/2/1/24/andrewyy/f_uhyqgj4m_40fb3dc.jpg

0

Share this post


Link to post
Share on other sites

Hm. I tried to make a theme, at it looks like 2d-background-right-bottom doesn't work like it should. when I try to make a theme where the size of the top piece and the size of the bottom piece are different, I get a strange glitch at the bottom right corner.

Also, I notice that you're telling the middle pieces to tile vertically, but it would work better if it was stretched.

here's an image showing both problems:

http://img37.imagefr...j4m_40fb3dc.jpg

Please, look at it more carefully :) I think it's okay, cause I've made a 2d skin with border, and it worked well. Anyway, skin-engine will become bigger in future, for now I have other items to be done. Hope I'll do them.

0

Share this post


Link to post
Share on other sites

lol, nothing happens when I doublecluck on XWD.exe... and task manager shows that it is running

Edited by Longi
0

Share this post


Link to post
Share on other sites

I'm the same as that of the Longi

---------------------------------

У Ð¼ÐµÐ½Ñ Ñ‚Ð¾Ð¶Ðµ Ñамое, что и у Longi

e7df517fc7c8t.jpg

0

Share this post


Link to post
Share on other sites

From the web site

Technical information

XWindows Dock provides fully compatibilities with Windows 7 and Windows Vista and probably works fine on Windows XP.

0

Share this post


Link to post
Share on other sites

Same here... Win7 Ultimate...starting oki XWD 2.0 ...but if I change skins, add OD docklets...and do a restart of XWD..not working anymore...

it is strange that I don't have nothing in TaskManager....

Dock has stopped working..and this is what it shows:

Problem signature:

Problem Event Name: APPCRASH

Application Name: XWD.exe

Application Version: 2.0.0.0

Application Timestamp: 4b5b3837

Fault Module Name: XWD.exe

Fault Module Version: 2.0.0.0

Fault Module Timestamp: 4b5b3837

Exception Code: c0000005

Exception Offset: 00006cd7

OS Version: 6.1.7100.2.0.0.256.1

Locale ID: 1048

Additional Information 1: 0a9e

Additional Information 2: 0a9e372d3b4ad19135b953a78882e789

Additional Information 3: 0a9e

Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

Edited by Elevati0n
0

Share this post


Link to post
Share on other sites

I guess I should note, on Windows 7 Home Basic there are no issues yet. I've changed skins added and removed short cuts, changed icons. Everything seems good so far.

0

Share this post


Link to post
Share on other sites

Same here... Win7 Ultimate...starting oki XWD 2.0 ...but if I change skins, add OD docklets...and do a restart of XWD..not working anymore...

it is strange that I don't have nothing in TaskManager....

Dock has stopped working..and this is what it shows:

Problem signature:

Problem Event Name: APPCRASH

Application Name: XWD.exe

Application Version: 2.0.0.0

Application Timestamp: 4b5b3837

Fault Module Name: XWD.exe

Fault Module Version: 2.0.0.0

Fault Module Timestamp: 4b5b3837

Exception Code: c0000005

Exception Offset: 00006cd7

OS Version: 6.1.7100.2.0.0.256.1

Locale ID: 1048

Additional Information 1: 0a9e

Additional Information 2: 0a9e372d3b4ad19135b953a78882e789

Additional Information 3: 0a9e

Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

Be carefull with OD Docklets, cause with several docklets dock doesn't work

0

Share this post


Link to post
Share on other sites

Yeah..i deleted Stacks Docklets from..and now I found that the skin I made it is the trouble...

If I delete it ..it's ok..

Why Andreyu skin works and mine not?:D

0

Share this post


Link to post
Share on other sites

Yeah..i deleted Stacks Docklets from..and now I found that the skin I made it is the trouble...

If I delete it ..it's ok..

Why Andreyu skin works and mine not?:D

Stacks Docklet works well. About skin:

1. Open Skins\Default\skin.ini and read very carefully every line of it.

2. Make similiar as default one.

Edit:

I've noticed that if your skin.ini isn't configured properly for your images, xwd may crash.

I will try to catch problems with it and fix them in the next release. Thanks.

0

Share this post


Link to post
Share on other sites

I've noticed that if your skin.ini isn't configured properly for your images, xwd may crash.

0

Share this post


Link to post
Share on other sites

Yeah...saw that too...

But I comment all those 2d lines..and set skin only for 3d..and same thing..

Please share your skin.ini with all that we can tell you where the problem is.

0

Share this post


Link to post
Share on other sites

im sorry but how to install it?after unzipped downloaded folder thats what i see on my desktop.please let me know how to do it?

windows 7 ultimate 32-bit

Edited by romeooh
0

Share this post


Link to post
Share on other sites

im sorry but how to install it?after unzipped downloaded folder thats what i see on my desktop.please let me know how to do it?

windows 7 ultimate 32-bit

1. Unzip it into a folder

2. Run XWD.exe

That's all.

0

Share this post


Link to post
Share on other sites

Ok..I paste it here..because i saw that new skin of Aqua=Soft no more file upload chance

[skin]

; Name of the skin, it's identificator for the dock

skin-name=Elevati0n

; Description about Author,Skin and etc.

skin-description=© Elevati0n

; Supported modes: 2d and/or 3d

dock-mode=3d

; Rect format: left,top,width,height

; Background

3d-background-image=background-3d.png

3d-background-rect=0,0,2624,92

; Background's opacity in percents (min=0, max=100)

3d-background-opacity=100

; Background's edge

3d-background-edge-image=background-edge-3d.png

3d-background-edge-rect=0,0,2624,9

; Offset from left and right side of the dock in pixels

3d-background-edge-offset=6

; Angle in degrees of the dock's panel

3d-background-edge-angle=18

; Separator for 3D mode

3d-separator-image=separator-3d.png

3d-separator-rect=0,0,70,180

; Indicator for 3D mode

3d-indicator-image=indicator-3d.png

3d-indicator-rect=0,0,410,200

3d-indicator-skip-bottom=10

; Reflection opacity in percents (min=0, max=100)

3d-reflection-opacity=25

; Enable=1, Disable=0 windows' reflection on dock

3d-reflection-enable=1

; Icons position on the dock (min=0, max=100)

3d-icon-position=30

3d-icon-size-between=2

3d-icon-reflection-skip-top=0

3d-icon-reflection-skip-bottom=0

3d-icon-reflection-offset=8

3d-icon-reflection-opacity=40

3d-icon-reflection-opacity-factor=100

0

Share this post


Link to post
Share on other sites

So, problems can be with images and there rect sections.

For example, check out if background-3d.png really smaller or equal 2624x92, or indicator-3d.png <= 410x200 ? And there are all of them placed at the same folder with skin.ini.

0

Share this post


Link to post
Share on other sites

Question: what happen if my .pngs sizes are not the same like whose in skin.ini?

That will be the problem with the crash?

It's oki now...thanks to Csongi. The cause was those png sizes ;)

Let's do awesome skin for thos awesome XWD 2.0 vers.

Do not double post, use the edit button - mps69

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0