Sign in to follow this  
Followers 0

Standalone Stack 2

188 posts in this topic

It seems I can't open a shortcut to this path:

"C:\Program Files\Adobe\Adobe Photoshop CS4 (64 Bit)\Photoshop.exe"

Could it be because of the "(" and ")" symbols?

Thanks!

0

Share this post


Link to post
Share on other sites

Why don't you try renaming the folder and taking out the ( and ) symbols? Is the problem fixed?

0

Share this post


Link to post
Share on other sites
Why don't you try renaming the folder and taking out the ( and ) symbols? Is the problem fixed?

Hi scissorhands7,

Honestly, I'm not necessarily getting this advice

How Poof can do that if

"C:\Program Files\Adobe\Adobe Photoshop CS4 (64 Bit)\"

is the legit and default folder for Photoshop installation (???)

Well,... if you mean just temporarily for testing the stack... but it's better to create a new folder with

brackets in the name and play with that one

My regards

0

Share this post


Link to post
Share on other sites

It seems that the problem has nothing to do with the brackets. Standalone Stack isn't able to show the shortcut icon and when I click on it I just gives me an unspecified error.

"C:\Program Files\Adobe\Adobe Photoshop CS4 (64 Bit)\Photoshop.exe"

just doesn't work... how strange :(

*EDIT*

I noticed that all shortcuts to files inside C:\Program Files\.. don't work. Even when I start Standalone Stack in administrator mode.

Shortcuts to C:\Program Files (86x)\... work fine

... what to do?

Edited by Poof
0

Share this post


Link to post
Share on other sites

I've noticed that folders (no matter what ones) can have problems being opened in standalonestack 2 if they have a shortcut in them that points to a program that does not exist. Sometimes I have gotten an error notifying me of this. However I suggest you root through your program files folder and make sure there are no shortcuts which point to nonexistant programs/items.

0

Share this post


Link to post
Share on other sites

great work on this app - i was searching by luck for somthing look like this flying menu in leopard - and found u :)

my Bug : in 2.0.6

i have a proplem in 2.0.6 - the stack it won't open i must wait between every click about 3 or 4 sec to can open the stack again with my shortcuts - even with the double click future the same and with the grid too the same proplem -

i installed 2.0.5 it work fine without this proplem

0

Share this post


Link to post
Share on other sites

Yep.. same problem. 2.0.5 was more "responsive" <_<

BTW "on click on a folder with CTRL key" why not use mouse2 button to do it (middle works like mouse1)?

os Win7

0

Share this post


Link to post
Share on other sites

How the heck do you USE the app???? There are no step-by-step instructions on the website or within the zip file. I extracted the files into a folder. If I double-click on StandaloneStack.exe I get an information window about Usage, which is incredibly un-informative, and that's the only thing visually that happens. A few times I dragged a folder full of shortcuts onto that .exe, the app comes up, and I have to again navigate to the folder full of shortcuts that I just dragged onto the exe, then when I click on Ok or somesuch...nothing happens; no new icon/shortcut on the desktop or in that folder. Now when I drag that folder or a shortcut to the folder onto StandaloneStack.exe, the beautiful fan opens up from StandaloneStack.exe upwards - and I can open programs from the fan, but that's it. Clicking on StandaloneStack.exe again only opens the un-informative info window. I cannot figure out how to get an icon on the taskbar which will open up the shortcuts I'm trying to fan out.

I'm sure I'm doing some simple thing wrong - but I've been a software junkie for over 25 years, and this is just frustrating. Thanks for anyone's help.

Of course I couldn't wait for a response and kept looking for the answer, and found this on a site which I'll link to below:

" Default Windows 7 mac style STACKS

check this out

Chris'n'Soft » StandaloneStack

worked as smooth as hell on windows 7

basically you download the .exe file make a shorcut and put it on your desktop

Right-click on this shortcut, choose properties.

At the end of “Target” field, enter the name of your stack, for example “desktop” (without quote “”).

( change the name for each stack you do)

example: C:\standalonestack\StandaloneStack.exe desktop

then double click it choose file

then pink to taskbar

and voilà!

to change icon I just changed the shortcuts icon in the windows

options"

I found this on:

http://www.sevenforums.com/customization/3...yle-stacks.html

And guess what - with INSTRUCTIONS I was able to accomplish it. I didn't see these kind of instructions anywhere on Chris's website, included with the program, or on this forum. So thanks very much Chris for the wonderful program, but please consider providing some STEP-BY-STEP instructions on HOW to use it.

And now that my rant is done and I've mastered this, please let me say - thanks Chris! This is exactly what I was looking for. I love Windows 7, but I also love that one bit about OS X, the stack. I tried another one called 7stacks, which does much the same - but it opened significantly slower than this one (on my home PC's anyway), and that really takes away from the experience. And this one looks better when it opens in grid mode - it's easier to see the icons and their text.

0

Share this post


Link to post
Share on other sites

Keep on topic guys - thread cleaned up

0

Share this post


Link to post
Share on other sites

Hi

I've a little problem with standalonestack 2 and windows 7. I use the x64 version of win 7, so I've two Program Files folder. One for 64bit apps and one for 32bit apps. Now is my problem, that standalonestack always give me that error message when I try to open a 64bit program over standalonestack 2:

---------------------

"Path to Shortcut"

The specified path does not exist.

Check the path, and then try again.

--------------------

For 32bit apps it works perfect.. any idea what the problem might be an how it can be solved?

regards

dimach

0

Share this post


Link to post
Share on other sites

The stack doesn't work properly on my secondary monitor. Works fine on my primary.

Primary:

primary1.png

Secondary:

secondary1.png

0

Share this post


Link to post
Share on other sites

Name Sorting Bug - Numerical

I'm almost positive this hasn't been addressed yet. I have found a bug that deals with the sorting of names. Primarily with numbers that are greater than 9.

I sort my Family Guy episodes by Season and then by episode. I have a folder for each season, and inside the folder are the episodes for that season.

Each episode is labeled according to its order

(Example: 1 - Name of Episode One, 2 - Name of Episode Two) This goes on up until 14 or 15 (14 - Name of Episode 14, 15 - Name of Episode Fifteen)

I would like to sort the files by name which i have selected so that the episodes appear in chronological order (1, 2, 3, 4, 5, 6 ...14, 15, 16)

However, instead of being sorted as shown above the numbers are sorted (1, 10, 11, 12, 13, 14, 15, 16, 17, 18, 19, 2, 20, 21, 22, 23...etc) As you can see its rather a bother.

I have a temporary fix which works fine it would just be nice if you could end up fixing this bug for the future. Currently I put a underscore in front of any numbers greater than 9 to fix it. (1, 2, 3, 4, 5, 6, 7, 8, 9, _10, _11, _12, _13)

post-92588-1254114075_thumb.jpg

0

Share this post


Link to post
Share on other sites

Hi! I love this application, but it's a bit slow on startup. Could you improve the performance?

You could use an in-memory cache for the icons, linked to the filenames. On popup only new shortcuts/icons are loaded from the filesystem.

We would all appreciate it!

0

Share this post


Link to post
Share on other sites

I'm trying to use this in the Retail Version of 7 Pro and I keep getting an error that says "Unknown Stack."

0

Share this post


Link to post
Share on other sites
Name Sorting Bug - Numerical

I'm almost positive this hasn't been addressed yet. I have found a bug that deals with the sorting of names. Primarily with numbers that are greater than 9.

I sort my Family Guy episodes by Season and then by episode. I have a folder for each season, and inside the folder are the episodes for that season.

Each episode is labeled according to its order

(Example: 1 - Name of Episode One, 2 - Name of Episode Two) This goes on up until 14 or 15 (14 - Name of Episode 14, 15 - Name of Episode Fifteen)

I would like to sort the files by name which i have selected so that the episodes appear in chronological order (1, 2, 3, 4, 5, 6 ...14, 15, 16)

However, instead of being sorted as shown above the numbers are sorted (1, 10, 11, 12, 13, 14, 15, 16, 17, 18, 19, 2, 20, 21, 22, 23...etc) As you can see its rather a bother.

I have a temporary fix which works fine it would just be nice if you could end up fixing this bug for the future. Currently I put a underscore in front of any numbers greater than 9 to fix it. (1, 2, 3, 4, 5, 6, 7, 8, 9, _10, _11, _12, _13)

also you can try to put a 0 before the one digit numbers (01,02,03,04,05,06,07,08,09,10,11,12,13)

0

Share this post


Link to post
Share on other sites
also you can try to put a 0 before the one digit numbers (01,02,03,04,05,06,07,08,09,10,11,12,13)

Yeah I found out that works out and looks a lot better. Good find.

0

Share this post


Link to post
Share on other sites
It seems that the problem has nothing to do with the brackets. Standalone Stack isn't able to show the shortcut icon and when I click on it I just gives me an unspecified error.

"C:\Program Files\Adobe\Adobe Photoshop CS4 (64 Bit)\Photoshop.exe"

just doesn't work... how strange :(

*EDIT*

I noticed that all shortcuts to files inside C:\Program Files\.. don't work. Even when I start Standalone Stack in administrator mode.

Shortcuts to C:\Program Files (86x)\... work fine

... what to do?

i have a work-around that i used, basically, create a symbolic link to the folder that contains your app in the Program Files directory, like so:

1. create a folder somewhere on your disk.

2. hold down shift on that folder, right-click and select open command window here.

3. type: mklink /D foldernameyoucreate "full path to original folder in quotes"

example: i created a folder called x64Fix on my disk to hold all my symbolic links for the apps that aren't working. i created my symbolic link inside of it like so (using photoshop as an example):

C:\x64Fix>mklink /D Photoshop "C:\Program Files\Adobe\Adobe Photoshop CS4 (64 Bit)"

4. verify message that symbolic link was created (you should also see a shortcut arrow on the Photoshop folder).

5. You should then have a folder path like C:\x64Fix\Photoshop

6. Create your shortcut for the jumplist from C:\x64Fix\Photoshop folder path to the exe rather than the real path.

so, instead of your shortcut being:

"C:\Program Files\Adobe\Adobe Photoshop CS4 (64 Bit)\Photoshop.exe"

it will be

"C:\x64Fix\Photoshop\Photoshop.exe"

also note, if you edit the shortcut you already have, make sure you change the icon and start in path to match the new path.

just so you know (if you don't), symbolic links are essentially shortcuts that windows manages. to get rid of the symbolic link, just delete the folder you created.

it's not pretty, but it buys us and the author some time to fix the issue.

Edited by reddevil7nine
0

Share this post


Link to post
Share on other sites

If you have any problems, check out the standalone stack / stack docklet known problems thread to see if there isn't a fix already.

Edited by scissorhands7
0

Share this post


Link to post
Share on other sites

Great post scissorhands7, this will help a lot of new users.

0

Share this post


Link to post
Share on other sites

That's what I was thinking, would it be possible to make this a new thread, and then lock and sticky it? This way I can add on/remove problems as they are fixed/made.

0

Share this post


Link to post
Share on other sites

Hi All !

sorry to be out for a long time... i was (and i'm again) busy with my work.

But be happy, soon i will have no more job :( ,i will have more time...but less money...so if you want to make me a donation your welcome... No, it's a joke :rolleyes: (about the donation, not about my job).

scissorhands7, wonderful thread about stack docklet and standalone stack ! thank you ! ;)

So, here is a new version ( download from the first page of this thread ) : 2.0.7

- Open speed improvement. Check "keep in memory when stack is closed" to activate cache. The file list is not reloaded from file system.

- Custom icon name is now like "_.doc" with underscore (XP can't create file without prefix like .doc )

- Fix location of stack if you force the position and then change screen resolution.

- Right click context menu.

- "click thru" on transparent part of the icon (for stack mode) now open the shortcut.

- Keep mouse button settings if button is swapped ( for lefty )

- you can force stack position on screen

- numerical sorting for filename. when filename begin with a number, it is used to sort the file.

- don't run shortcut if you hold down mouse button more than 2 seconds

- video shortcut preview and animation

- you can turn off video preview

- "A stack/folder in the stack can not be opened if it contains the shortcut of deleted application" should work ?

- stack shortcut creation can be made in any folder ( instead of desktop folder only)

sorry for 64bit application, i can't compile standalone stack in 64bit because stack lib dll from Matonga is 32bit so i can't load it.

i will try another thing later...

and i think about a great improvement too, but i need some time...

I can't do all you want because of the stack dll from Matonga, i hope the new version is coming soon :rolleyes:

0

Share this post


Link to post
Share on other sites

1. thank you for this wonderful update!!!

2. I'm still getting the "the parameter is incorrect error" on specific icons :(

3. also not all icons highlight when i hover over them even tho i can still successfully click on them.

I have XP SP3

Edited by Skrell
0

Share this post


Link to post
Share on other sites

Excellent work. In my case, though the opening is faster enough, the navigation between folders inside the stack and grid mode is much slower than the previous version (2.06). I'm running XP.

0

Share this post


Link to post
Share on other sites

Excellent!

I figured, I have no clue how to do any coding, but I can at least help you guys out by organizing things.

Keep up the great work Chris S. We all appreciate it.

One problem for me at least. I liked the cache/

"- Open speed improvement. Check "keep in memory when stack is closed" to activate cache. The file list is not reloaded from file system."

Way better in the last version. This version, if I close out of a stack by clicking off the screen, the stack remembers what folder I had last opened. For example If I navigated through to --->Media --->Movies --> Classic and then decide, nah I don't want to watch a movie after all and click off the screen to close the stack, then decide hey lets play a pc game. So I click on my media stack but instead of it displaying my pc games folder along with my movies, pictures, music folders etc. It comes up with the last opened folder, which in this example was my classic movies folder.

Not a big fan of that feature and it would be cool if we could keep the cache/stack in memory and disable this feature.

Also another problem with that feature. Yes the initial opening speed is faster with keeping the stack in memory, however If I Open my media stack, I'm like wow that was faster, but then if i click on my pc games folder within the media stack, there is a .5 second time of delay where the stack closes (as if to open the folder in the stack) but there is a .5 second delay where nothing happens, and then the folder opens. In the last version with the stack in memory, this was not an issue and the new folder opened immediately (at least for me)

All of the other features are excellent and fix a lot of bugs, thanks man

Edited by scissorhands7
0

Share this post


Link to post
Share on other sites

This is exactly the kind of thing I need! Quick question, though... the Grid opens above where the mouse is clicked instead of in a fixed place beside the linked icon/text/whatever. I thought the "Force Open Position" options would let me fix that, but they don't seem to be doing anything at all. Any way I can make this work how I'd like it to? Thanks.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0