Sign in to follow this  
Followers 0

Pidlshortcuts Disappear With "show Desktop"

10 posts in this topic

PidlShortcuts disappear when I right-click on the taskbar and hit "Show Desktop". I have to open a window or application in order for them to reappear. Strangely, WIN+M works perfectly fine - but I'm so used to doing it lights-speed with the mouse that win+m is a hindrance to my normal computer usage. :/

Is there a way to fix this? Theres probably a setting I can't find or something. ;O

0

Share this post


Link to post
Share on other sites

What does it do when you press Win+D?

Maybe your Pidls aren't at "Desktop Icon" in the z-level...?

0

Share this post


Link to post
Share on other sites
What does it do when you press Win+D?

Maybe your Pidls aren't at "Desktop Icon" in the z-level...?

Yeah, they're not. Two things happen when I do that; Let me explain.

1. If I just created the shortcut, when it's at Desktop level it stays at the foreground no matter what window is open/maximized. It's always showing.

2. a. After I edit the shortcut and switch it to Desktop level, it completely disappears. It's nowhere. The only way I can get it back it by setting it to another level.

b. Or the label will disappear, and the icon will be showing. But it will still be on-top of everything, showing all the time.

So I keep it on "Always on the bottom". It does everything it should, other than that. WIN+D also makes them all disappear like "Show Desktop". However, When I have them set to desktop-level, they remain. However the problem is, they remain no matter what is showing though >_<

Tried to edit. ><

I'll post screenshots if needed after work.

Ok, here are some screenshots of what I mean(sorry for the file size, didn't notice until I already uploaded them ><).

Here is how I would like them to behave(Style: Always-On-Bottom):

http://www.box.net/shared/static/8vvi339cfy.jpg

Here is how it behaves with 'Style: Desktop Icon' (Notice the missing label and how it sits in front of the control panel window):

http://www.box.net/shared/static/evdtih1m6s.jpg

No labels and it sticks in front of every window. >< I know that can't be the intended effect, but I don't know how to fix it.

Do not double post - the edit function - mps69

Edited by mps69
0

Share this post


Link to post
Share on other sites

Ok, well there's a few things here. First, your problem is definitely with the "Desktop Icon" option; you see if your items are Normal, Always bottom or Always top they will react to the z-order of windows. That's why when you Win+D (or 'Show desktop') they disappear: that command sayd "hide everything that's up and show me the desktop". Oppositely Win+M says "Minimise all maximised windows", which is why your items stay there: even if they react to the window z-order, they don't react to a command directed only at windows. Makes sense?

Anyway, all I mean to say is that as long as your items are not at "Desktop icon" level, they will react like this and it's normal.

Now... for the other issue, try the following:

- Which version are you using (I believe I recognize 1.3...?) If it's 1.4, revert to 1.3. On XP you don't need anything in 1.4 and found it was REALLY buggy all together.

- Try Closing this desklet and recreating a completely different one, with different icon and path. Sounds weird but sometimes Ave reuses prior configs so starting anew might help.

- If that doesn't work, try creating a new theme all together.

Let me know how it reacts, and we'll go from there.

Edited by technosinner
0

Share this post


Link to post
Share on other sites
Ok, well there's a few things here. First, your problem is definitely with the "Desktop Icon" option; you see if your items are Normal, Always bottom or Always top they will react to the z-order of windows. That's why when you Win+D (or 'Show desktop') they disappear: that command sayd "hide everything that's up and show me the desktop". Oppositely Win+M says "Minimise all maximised windows", which is why your items stay there: even if they react to the window z-order, they don't react to a command directed only at windows. Makes sense?

Understood.

- Which version are you using (I believe I recognize 1.3...?) If it's 1.4, revert to 1.3. On XP you don't need anything in 1.4 and found it was REALLY buggy all together.

The only place I could find with a working download was from http://www.avedesk.org/ (correct me if i'm wrong), and From what I gather from these forums is that the version advertised on that site is 1.4, but in actuality it's 1.3, and 1.4 is nothing but a compatibility build for Vista(which I found Here). In either case, I've tried both.

- Try Closing this desklet and recreating a completely different one, with different icon and path. Sounds weird but sometimes Ave reuses prior configs so starting anew might help.

Tried it by doing a regular folder("C:\folder"), with a shell command folder eg shell:Common Documents, and with a plain harddrive eg D:\. Deleted old desklet and create a new one each time.

- If that doesn't work, try creating a new theme all together.

Tried as well. ='( When I switched back to 1.3, I even went into my App Data folder and deleted all the files in AveDesk to ensure everything would be fresh. (Just FYI, I also made a new theme through the control panel for giggles)

I'm at a loss, and starting to think that it is a bug that affects just me. =*(

0

Share this post


Link to post
Share on other sites

Ok... well from the screenshots (that's I've taken a better look at...) seems you have 1.4. I had similar bugs with that version (only one item showing, screwed up labels, etc). Try downloading v1.3 here (the secret magic site nobody ever remembers exists ;) ).

If THAT doesn't work, I honestly can't see why you would have such a strange bug... but we'll cross that bridge then.

0

Share this post


Link to post
Share on other sites

v1.3 Solved it! Thank you <3!

And looking at that URL, I feel like an idiot for not being able to find it myself.

0

Share this post


Link to post
Share on other sites

Hey no worries, I had to google it myself to remember. I don't think its actually posted anywhere here. But happy it helped! (I had a feeling that was the problem ;) )

0

Share this post


Link to post
Share on other sites

I'm getting this error too, I'm using Windows 7 x64 with compatibility mode enabled for Avedesk 1.3. When I use Always Bottom mode the icons disappear when I click show desktop and when I use Desktop Icon mode the icon disappears all together. Any ideas?

0

Share this post


Link to post
Share on other sites

I have a similar problem :(

I'm using Win7 64 and i've already downgraded from 1.4 to 1.3.

My Problem is that if I use an other option than "desktop icon" my PidlShortcut disapears when i hit "Show Desktop", but i guess this is how its suppossed to be;

but when I use the option "desktop icon" the PidlShortcut doesnt appear on my desk at all!!

I can click on it, but there is no icon or label on my desk :(

thanks for the help ...

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0