Sign in to follow this  
Followers 0

[release] Photobooth Clone!

80 posts in this topic

Okay guys, I have been working on this making i my day project, and it seems like its ready for the public.

I found this Flash file a pretty long time ago, and it was a GREAT flash clone of Photobooth. I recently have been using it a lot, and it bugged me that every time I wanted to use this Photobooth clone, I had to open FireFox up, hope it doesnt crash (from my 20 tabs), and then finally it would work (slowly).

I decided I would implement the flash into an application, and mod a few things on the flash swf file to make it more Photobooth-like. It really isn't much of an application, or my best coding (in fact, this is only a few lines of actual VB code), but so far it has proven itself worthy.

Here is 2 screenshot of the app.

PhotoboothSCREEN1.png

PhotoboothSCREEN4.png

Here is the Photobooth.exe icon (Thought it looked weird, to see a Mac application with a .exe on the end =P)

PhotoboothSCREEN2.png

This application features a Flikr upload, and Facebook Upload for your convinience =P. You can also chose to just save the file.

PhotoboothSCREEN3.png

PictureBooth flash SWF originally created by Karthik.

Flash and Application integreation by jchaike.

Download link:

http://ttm.net76.net/downloads/Photobooth/Photobooth.zip

Mirrors:

(feel free to post a mirror link!)

I hope you guys enjoy this application! If you have any suggestions, feel free to post them =D.

ALL IMAGES ARE © AND OWNED BY APPLE INC.

Download here:

Photobooth.zip

Edited by jchaike
0

Share this post


Link to post
Share on other sites

wow amazing!

i dont really use webcams but when i do ima use this forsure

0

Share this post


Link to post
Share on other sites

Dude, I will try this out when I get home. It looks pretty from the screens you posted. :o

0

Share this post


Link to post
Share on other sites

Well, the .exe won't accept my microphone/camera setup. But for some reason when I run it from the .swf it runs perfectly.I'm hoping for support for the backdrops in later development. Keep up the good work, it's fantastic.

0

Share this post


Link to post
Share on other sites
Well, the .exe won't accept my microphone/camera setup. But for some reason when I run it from the .swf it runs perfectly.I'm hoping for support for the backdrops in later development. Keep up the good work, it's fantastic.

I had a similar problem. I got it working this way:

1. Run the .swf file directly, by dragging and dropping into some web browser (Google Chrome in my case, though I know for sure this will work with Firefox too, because I've done that before).

2. The Flash Player will then ask you to allow "local" to use microphone and webcam. First click the "remember setting" or "always enable" or... I can't remember. It's the only checkbox there, so you can't miss it. :)

3. Then click allow... or was it enable... I need some sleep.

4. You'll see the app working, but inside a web browser.

5. Close the browser window of Photobooth (if you're using a tabbed browser, close the tab).

6. Run Photobooth.exe file. Now it should work without problems.

0

Share this post


Link to post
Share on other sites

Thanks for that SWF file...

THINGS I DON'T LIKE

- It's weird, but it seems that modifying settings for Flash Player is not possible with that executable.

- It doesn't appear as WinExposé snapshots.

- I'd wanted to have rounded window's corner.

- Unmovable window

* And even worst, I don't like the message in the right top corner with a button to close which doesn't close ;(

But hey, don't get mad at me because I also did another executable with those things fixed, at least is working perfectly on my PC.

So, I also wanted to share it and see if it works on your computers.

This is an screenshot...

photoboothsample2.jpg

Get it here: Photobooth.zip

BTW: It's an standalone exefile which needs to extract the SWF file to the temporary folder

PS: Sorry about my bad English.

Edited by vigil
0

Share this post


Link to post
Share on other sites

Both versions fail to work at my Vista notebook, even after following what matonga has explained. In either case the application opens, the webcam indicator lights up, but no image can be seen. Opening the swf file from the first app in FF works fine tho.

0

Share this post


Link to post
Share on other sites

I don't know about Vista, but I also tested on Win7 and it works correctly

NEW:

I added the Animated Backgrounds in the third page of effects which weren't present in the previous exefile, so there are 8 more files inside the standalone exefile as you can see in the screenshot.

w7.jpg

Running on Win7 with 5 animated backgrounds and 3 static ones

You can get it here: PhotoBooth + BG 4.9 MB (5,057,998 bytes)

Just if you don't know, the following......

Requirements:

- Adobe Flash Player 10.

- A webcam :P (or a virtual one like Manycam).

To remember settings : Right click and choose Settings and in privacy section choose Allow and check Remember. There you can also choose the Camera and many other options.

Edited by vigil
0

Share this post


Link to post
Share on other sites

hello vigil..now i knw why it nt working on mine cz ur app for window7???? im using xp sp2.can u make one for all xp user.tnx

Edited by danhoven
0

Share this post


Link to post
Share on other sites
hello vigil..now i knw why it nt working on mine cz ur app for window7???? im using xp sp2.can u make one for all xp user.tnx

I have SP2 and it works fine =P

This app is great, I am glad I was able to get the idea out, and have someone else improve it =D

Hopefully people will spread the app and this will get a lot of downloads

0

Share this post


Link to post
Share on other sites
I have SP2 and it works fine =P

This app is great, I am glad I was able to get the idea out, and have someone else improve it =D

Hopefully people will spread the app and this will get a lot of downloads

Hi, I tested it at a friend's who has an integrated webcam in his notebook.

Everything great but the animated backgrounds.

When we tried them, it shows "please step out of the frame", but nothing else happens. We stepped out of the frame and stayed out several seconds. Tried clicking the screen, the "please step..." text, even the red camera button (which just took a photo of the curtains and the wall).

Did I miss something? :huh:

0

Share this post


Link to post
Share on other sites
Hi, I tested it at a friend's who has an integrated webcam in his notebook.

Everything great but the animated backgrounds.

When we tried them, it shows "please step out of the frame", but nothing else happens. We stepped out of the frame and stayed out several seconds. Tried clicking the screen, the "please step..." text, even the red camera button (which just took a photo of the curtains and the wall).

Did I miss something? :huh:

lol, that's weird

in the fix that was posted, it seemed to work pretty well. it didn't really detect the background perfectly, but it was still pretty good =D

0

Share this post


Link to post
Share on other sites
Both versions fail to work at my Vista notebook, even after following what matonga has explained. In either case the application opens, the webcam indicator lights up, but no image can be seen. Opening the swf file from the first app in FF works fine tho.

I feel your pain :(

0

Share this post


Link to post
Share on other sites
Hi, I tested it at a friend's who has an integrated webcam in his notebook.

Everything great but the animated backgrounds.

When we tried them, it shows "please step out of the frame", but nothing else happens. We stepped out of the frame and stayed out several seconds. Tried clicking the screen, the "please step..." text, even the red camera button (which just took a photo of the curtains and the wall).

Did I miss something? :huh:

I'm sorry I didn't mention that. I have the same problem with Windows7.

However, in Windows XP SP3 it works fantastic (it replaces the background :D )

Maybe is something related to the version of Flash Player or Windows, besides in Win7 I got error while playing for example Youtube at fullscreen after a while.

BTW, you can see if it works at their original location: http://kpicturebooth.com/.

PS: I just used WebBrowser component of Delphi ;)

lol, that's weird

in the fix that was posted, it seemed to work pretty well. it didn't really detect the background perfectly, but it was still pretty good =D

Yeah. I don't know about yours but my webcam for example had AutoMode Control activated, I mean Exposure and Whitebalance which it means that automatically the webcam tried to find the right balance and that's why it affected the color and consequently background appeared and disappeared depending on my movements (near, far, other things on scene, etc). I deactivated and now works better :D.

However, since the background color is not totally different to the actor's clothes and skin (everything that is wanted to be shown), it will considere a similar color of the background as transparent.

A well illuminated green background would be great.

And don't forget, also shades affect.

Edited by vigil
0

Share this post


Link to post
Share on other sites

i tried again.i stil got this..how can i solve this.i got this msg.

post-87488-1234941149_thumb.png

0

Share this post


Link to post
Share on other sites
i tried again.i stil got this..how can i solve this.i got this msg.

Are you sure you had Flash Player 10 installed - because maybe you only have the plugin for Netscape like browsers, like Gecko browsers (Firefox), Opera and not the ActiveX for Internet Explorer.

It's needed for IE, because AFAIK there are different installers.

Please try to open that swf with IE (the one available in the first post) and if it shows the same error, go to adobe http://www.adobe.com/go/EN_US-H-GET-FLASH from within IE Browser.

I have been testing with Flash7, Flash8, Flash9 and Flash10 and only works with the latest one.

______________________________________________________________________________

Also , if you have Internet Explorer 7 or (Internet Explorer 6 in Windows Server 2003 Service Pack 2)this problem occurs if the following conditions are true:

The Allow active content to run in files on My Computer check box is selected in Internet Explorer 7.

Note To locate this check box in Internet Explorer 7, click Internet Options on the Tools menu, and then click the Advanced tab. Under Security, you can see the Allow active content to run in files on My Computer check box.

Cause:

This problem occurs because the FEATURE_BLOCK_LMZ_SCRIPT registry key prevents the execution of a script file in the local machine zone when the file is hosted in an Internet zone HTML page or an intranet zone HTML page.

The FEATURE_BLOCK_LMZ_SCRIPT registry key is a new security registry key that was added in Internet Explorer 7. When you open an ActiveX control-based MIME handler (which is exactly what this program does), Internet Explorer 7 creates a hidden HTML page that contains a reference to an external script. The script dynamically inserts the ActiveX control. Because of the FEATURE_BLOCK_LMZ_SCRIPT registry key, the script content is set to a buffer that contains only the 0x01 value. Additionally, the script is blocked.

The solution about that is located here: http://support.microsoft.com/kb/934366/en-us

0

Share this post


Link to post
Share on other sites

tnx for ur concern..il try it again..and sorry coz im using internet explorer 6 because most of the time i used safari web browser. and yes i have adobe flash player 10 d latest one. so i have to do is update ie6 to 7...tnx vigil!!

hey vigil..its work now!!!.after i update my ie6 to ie 7.tnx for ur guide..nice application.thnx!!!. :lol: :lol: :D

Edited by danhoven
0

Share this post


Link to post
Share on other sites

@vigil : works great in my son ASSUS notebook XP SP3 (PhotoBooth + BG), don't know if you can add shadowed underneath cause the y'z shadowed doesn't work on it, thank's a lot

0

Share this post


Link to post
Share on other sites

I'm actually the author of this application and I"m surprised that there are people here using it and repackaging it. If there is interests, I will make an updated version which runs on adobe AIR and allow better integration with the desktop and enable the movie feature. As for the app itself, you will need flash player 10 installed because the application uses pixelbender filters which are only available in FP10.

cheerz

Karthik

0

Share this post


Link to post
Share on other sites

@Karthik: thanks for this great clone! Your continued work is and will be very appreciated! :D

0

Share this post


Link to post
Share on other sites
I'm actually the author of this application and I"m surprised that there are people here using it and repackaging it. If there is interests, I will make an updated version which runs on adobe AIR and allow better integration with the desktop and enable the movie feature. As for the app itself, you will need flash player 10 installed because the application uses pixelbender filters which are only available in FP10.

cheerz

Karthik

i hope you aren't like, offended or anything. I thought it was a great flash product, and I kept your name intact, because, after all, you are the creator, I simply repacked it to make it an EXE. I didn't want credit for the actual application, just the idea to put it in a GUI and run as an EXE.

i tried contacting you (I think i left a blog comment?) a while ago, and you never responded.

sorry again

Edited by jchaike
0

Share this post


Link to post
Share on other sites

In the frame where needs to be me, i only see a grey block and a black block in the upper left corner and in that block are white letters saying "Your Msg"

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0