Sign in to follow this  
Followers 0

AveDesk 1.3 Bug report thread

193 posts in this topic

Bug description: Explorer window refreshes itself every couple seconds. Creates a constant flickering effect. Very annoying.

Items involved: Explorer and AveDesk (1.2 & 1.3)

Windows Version: XP Pro SP 2

DirectX version: 9.0c

System specs: Athlon XP 3000+ 2.2ghz, 1.5gb PC2700 DDR RAM

Graphics card & drivers version: GeForce4 Ti 4200 with 64mb of RAM, ForceWare 81.85 Drivers

Desklets running: PIDL Shortcut to C, D, & Recycle Bin; Sticky Notes (Notes in 1.2)

Steps to reproduce: There are no steps. Just have to run these desklets on my system and watch an explorer window spaz out.

0

Share this post


Link to post
Share on other sites
Bug description: Explorer window refreshes itself every couple seconds. Creates a constant flickering effect. Very annoying.

Items involved: Explorer and AveDesk (1.2 & 1.3)

Windows Version: XP Pro SP 2

DirectX version: 9.0c

System specs: Athlon XP 3000+ 2.2ghz, 1.5gb PC2700 DDR RAM

Graphics card & drivers version: GeForce4 Ti 4200 with 64mb of RAM, ForceWare 81.85 Drivers

Desklets running: PIDL Shortcut to C, D, & Recycle Bin; Sticky Notes (Notes in 1.2)

Steps to reproduce: There are no steps. Just have to run these desklets on my system and watch an explorer window spaz out.

@schmeckt gut

do you get it in Firefox too? i get a flickering drop down menu in webpages like at deviantart when browsing. not sure whether it is related to AVEDESK. shrug

0

Share this post


Link to post
Share on other sites
@_cell...you requested that Keyboard shortcuts work...did I miss something? :slant:

-NC

As for shortcuts - I don't remember myself using them earlier :)) But just decided to start and found them not functioning :))

Guess this is an issue worth mentioning here as far as shortcuts are declared and don't work :)

0

Share this post


Link to post
Share on other sites
AS for the problem i was having...forget it!

I just used the desklets in Avedesk 1.1

thats what your supposed to do, take the desklets thats missing from 1.1 to 1.3. and thats it.

0

Share this post


Link to post
Share on other sites

Has the showcase bug been solved?

Windows Version: XP Pro SP 1

DirectX version: 9.0c

System specs: Intel Graphics, 1GB RAM

Desklets running: PIDL Shortcut to C (set up to showcase)

Showcase doesnt show the only desklet set up to showcase (F8).

- - - -

Julieta, Italian Girl Power

0

Share this post


Link to post
Share on other sites

Bug description: PidlShortcut mounted by automounter loses icon, when non-system icons are used.

Items involved: default PidlShortcut desklet, default automounter module

Windows Version: WinXP Pro SP2

DirectX version: 9.0c

System specs:P4 2,53, 1GB Ram

Graphics card & drivers version:Radeon X800 Pro. Detonator 5.10

Desklets running:Several PidlShortcut desklets

Steps to reproduce:

1. Run avedesk with automounter

2. Insert disc (flash or cd - any removable) into drive.

3. Go to Desklet Properties of the appeared PidlShortcut

4. Go to Icon tab and select Use Custom Images.

5. Select any other image or icon, press apply. Now the desklet has non-system icon.

6. Close Desklet Properties and remove the removable media then insert it back.

7. The label and sublabel appear but the icon does not.

Special notes:

The icon appears as soon as i do something icon-related in desklet settings. Like rotate the icon or add shadow.

Here is the picture of the problem:

I set the icon for flash drive: http://www.modlabs.net/laik/ave1.jpg

I removed it and put it back: http://www.modlabs.net/laik/ave2.jpg

The bug does not appear in avedesk 1.2 on my system.

0

Share this post


Link to post
Share on other sites

@LaikrodiZ: This bug is known, but not everyone is able to reproduce it... Do you get the same behaviour duplicating a shortcut ?

for the moment, you can use this PidlFix effectlet to force a single redraw when the desklet is create. I'm going to update the MoveItIn effect with the same feature, for those who use it.

PidlFix.zip

0

Share this post


Link to post
Share on other sites

dreadnaut, thank you very much! It helped!

BTW, when i just dublicate an item, it has an icon. But if the dublicated icon is also for removable drive - it loses icon on next remove-insert.

0

Share this post


Link to post
Share on other sites

Well: all works now. I don't know if somebody had read my post about AveTunes and the CD Covers. It doesn't matter now, because after install it with the (incredible) installer, AveTunes works perfectly. Thanks Andreas!

0

Share this post


Link to post
Share on other sites

Yeah, Andreas, I double the report about Cyrillic symbols in Sticky Notes and Translator. Seems like they are inputed in Unicode, because every time I press a key (in Russian, of course) I get 2 symbols. But then the text is displayed incorrectly.

0

Share this post


Link to post
Share on other sites

Bug description: Cannot find "folder" and "drive" on "Desklet add" menu on Avedesk 1.3 Installer.

Items involved: default PidlShortcut desklet, default automounter module

Windows Version: WinXP Pro SP2

DirectX version: 9.0c

System specs:P4 2.6, 1GB RAM

0

Share this post


Link to post
Share on other sites
@LaikrodiZ: This bug is known, but not everyone is able to reproduce it... Do you get the same behaviour duplicating a shortcut ?

for the moment, you can use this PidlFix effectlet to force a single redraw when the desklet is create. I'm going to update the MoveItIn effect with the same feature, for those who use it.

Hi dreadnaut,

Until AndreasV finally gets the time to fully investigate_explore these various issues with v1.3...I too am getting the mysterious pidl-shortcut icons disappearing on my three used desklets after re-boots: Full details on completed Bug Report Pg2...

Just to try your PidlFix file would I just unzip it into my desklet directory with my AveDesk1.3 ?

0

Share this post


Link to post
Share on other sites

I didn't think of makeing an installer :) it's an effectlet: it goes in the Effects folder and you have to apply it to the disappearing desklets. It's actually a single line: a Desklet.Redraw() that is executed when the desklet is created

0

Share this post


Link to post
Share on other sites
I didn't think of makeing an installer :) it's an effectlet: it goes in the Effects folder and you have to apply it to the disappearing desklets. It's actually a single line: a Desklet.Redraw() that is executed when the desklet is created

Thank you for your promp_clear explanation...:)

I now have it applied correctly in the right Effects directory, so will give-it-go on all 3 of my pidl-shortcut desklets to see if it indeed helps.

0

Share this post


Link to post
Share on other sites

Bug description:Avedesk immediatly crashes upon opening any weather config file using sysstats

Items involved:sysstats - weather configs

Windows Version:Windows XP Pro sp2

DirectX version:9.0c

System specs:Athlon 64 3000+, 1gb ram, 2hdds 80gbs

Graphics card & drivers version:Geforce 5200; 81.85

Desklets running:5x PidlShortcut

Steps to reproduce:

1-Open Avedesk, open any of the weather configs and Avedesk will close(crash), sometimes it will load with null values shown and then once you mouse over or click to configure it will then crash

2-Ave will also crash sometimes with any of the configs opened by right clicking on the config and choosing 'Configure...'.

Special notes: I also have problems with time configs updating. I apologize if this is in the wrong bug thread.

0

Share this post


Link to post
Share on other sites

Bug description: My Favorites keys on microsoft keyboards cause ShowCase to fire without showing any desklets

Items involved: ShowCase

Windows Version: XP SP2

DirectX version: 9.0c

System specs: athlon xp 2600+, 1 gb ddr ram

Graphics card & drivers version: radeon 9700 pro, cat 5.10

Desklets running: just a bunch of pidlshortcuts

Steps to reproduce:

1. Enable showcase in global settings

2. Press any of the favorites hotkeys on the keyboard

Special notes:

Doesn't matter if the favorites key is bound to something or if there is any shortcut to activate ShowCase in Global Settings.

Occurs with my keyboard at work and at home.

0

Share this post


Link to post
Share on other sites
Hi dreadnaut,

Until AndreasV finally gets the time to fully investigate_explore these various issues with v1.3...I too am getting the mysterious pidl-shortcut icons disappearing on my three used desklets after re-boots: Full details on completed Bug Report Pg2...

Just to try your PidlFix file would I just unzip it into my desklet directory with my AveDesk1.3 ?

Hello dreadnaut,

Just wanted to follow-up with as I have had all 3 of my pidl-shortcuts set with your pidfix effectlet file, and have run v1.3 for 2-3 days and now 'no disappearing icon after rebooting'...:)

0

Share this post


Link to post
Share on other sites

Bug description: Systats-based Weather desklets lose components

Items involved: Judge's AeroWeather; location CIXX0020

Windows Version: WinXP Pro SP2 spanish

DirectX version: 9.0c

System specs: Athlon XP 2500+; 512 RAM

Graphics card & drivers version: nVidia GForce 4 MX440, ForceWare 81.85

Desklets running: PIDL Shortcut, Aero Weather on SysStats 2.5.8

Steps to reproduce:

1. Install AeroWeather

2. Set any location (CIXX0020 in my case)

3. When shutting down the system, let Windows force AveDesk to shut down (I've got a dialog telling me to force the shut down of an aplication called "A desklet")

Special notes: It causes the desklet to lose some of its visible components. Here, it has lost the bottom bar:

systats2nx.gif

0

Share this post


Link to post
Share on other sites

Bug description: SysStats docklets that require hardware meters (like network controls, CPU, etc.) will get corrupted as soon as you edit the meters for your own machine.

Items involved: SysStats docklets with Hardware meters

Windows Version: Windows XP Pro SP2

DirectX version: 9.0c

System specs:AMD 2600+, 1 gb of DDR RAM

Graphics card & drivers version: nVidia 6600 AGP with 128 mb RAM, Latest Official Drivers.

Desklets running: Gmail, 2 HD icons, DTP and network and CPU usage docklets of SysStats.

Steps to reproduce:

1. Create a SysStats Network meter.

2. Edit the meters in the docklet (the ones with hardware tabs.)

3. Click OK and close the SysStats configuration window.

4. Check the ini file of the docklet. You will see that it is corrupted after [meter] part.

Special notes: I am sure this is about the meters configuration because I can play with ANY other setting in SysStats configuration and save. Nothing gets corrupted. But if I edit the meters, they will work as far as I leave the AveDesk open. But as soon as I close and restart AveDesk, the blue question mark appears instead of the docklet (because ini file is cleared of anything after [meters] part as soon as you click OK, so overlay and graphics settings are gone). I have a clean install of XP and am sure that no virus, trojan, spyware is in my computer (Formatted, installed XP and started configuring my desktop). I hope you manage to find the problem. Good luck!

_________________________________________

0

Share this post


Link to post
Share on other sites

Bug description: Docklets/desklets disappear after clicking ok on desklet/docklet settings.

Windows Version: Windows XP Pro SP2

DirectX version: 9.0c

System specs: AMD 2000+, 1 gb of DDR RAM

Graphics card & drivers version: ATI X700 (256 DDR3) Omega 2675 drivers

Desklets running: Any of them

Steps to reproduce: Set desklets/docklets to always on bottom.

Special notes: Using Litestep. Setting desklets/docklets to desktop icon makes them appear on top of all windows.

0

Share this post


Link to post
Share on other sites

Bug description: AveDesk crashes when I am trying to add "Hide Desktop Icons" desklet

Windows Version: Windows XP Pro SP1

DirectX version: 9.0c

System specs: Celeron D 336, 1 gb of DDR2 RAM

Graphics card & drivers version: Nvidia GF6600 (128Mb), driver version 78.01

Does anyone on Intel processor have this problem while using Hide Desktop Icons desklet? Bug report mentions AMD processor, and in the past I also had some incompatibility when applications addresses to 3D Now instructions and then crushes (also I had similar problem with one of the VirtualDub filters).

0

Share this post


Link to post
Share on other sites

Bug description: Adding a PidlShortcut via: Control Panel's Menubar: Desklets->add.. and clicking on the top level PidlShortcut entry on the left side of the "Add Desklet" Window, then clicking the "Add Item" button, causes the Default Desklet to appear but as a "AveDesk Tutorial" Desklet. This does not seem right.

Items involved: PIDL shortcut

Windows Version: Windows XP Pro SP2

DirectX version: 9.0c

System specs: Pentium 4 3.2ghz, 1gb of DDR RAM

Graphics card & drivers version: Ati Mobility Redeon x600 with 256mb of RAM, Driver version 6.14.10.6530

Desklets running: AveScripter:Calendar, AveScripter:Calculator, AveScripter:PictureViewer, AveScripter: D-Weather

Steps to reproduce:

1. Open AveDesk Control Panel

2. From MenuBar: Desklets->add..

3. Select the top level "[+]PidlShortcut" and click the "Add Item" Button.

4. An "AveDesk Tutorial" Desklet appears in the control panel

Special notes: Additionally, I have a usability request:

If you have the control panel open, then minimize it to the taskbar. Then forget that it is already open and try to:

1) Double click on the AD Systray Icon (or)

2) Right click the systray icon and select: "Desklet Control Panel"

The (already opened) Control Panel remains minimized on the taskbar and for all outward appearances, nothing happens. One might think that something went wrong.

Suggested corrective action:

If control panel is already opened and minimized, when a user tries to invoke it again, have the control panel be restored to the desktop.

Thanks again,

Leon

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0