Sign in to follow this  
Followers 0

AveDesk 1.3

274 posts in this topic

yeah, kgraphik, the good installer is what AveDesk 1.3 missed!

0

Share this post


Link to post
Share on other sites

Nice, kgraphik, what are you using? I was thinking on doing a installation for AveDesk using Inno Setup. What are you using?

0

Share this post


Link to post
Share on other sites

Since there isn't too much to do with AveDesk while installing, even WinRAR would be fine. But my idea was also InnoSetup.

0

Share this post


Link to post
Share on other sites

Hm,Andreas, did you work on the PIDL-Shortcuts?

I would really like to have the Automounter working with network drives - @home and @work I am connected to several drives - right now the shortcuts don't vanish, when I disconnect from the (Samba-) homenetwork. (@work there is a Netware Server - still didn't test there)

0

Share this post


Link to post
Share on other sites
Updated the first screeny with a new banner for the installer. :)

Where download It?. Is good job, man. Thanks. :)

0

Share this post


Link to post
Share on other sites

You can't download it (yet?). I have to get permission from Ave to post the installer.

0

Share this post


Link to post
Share on other sites

@kgraphik: you got permission hereby. Thanks for your work :) I'm really want to put this up on avedesk.needlemen.com, but the next 5 days, I have really no time :(

0

Share this post


Link to post
Share on other sites
Hm,Andreas, did you work on the PIDL-Shortcuts?

I would really like to have the Automounter working with network drives - @home and @work I am connected to several drives - right now the shortcuts don't vanish, when I disconnect from the (Samba-) homenetwork. (@work there is a Netware Server - still didn't test there)

Fixed some small threading issues on the pidl-shortcut, other than that its pretty much all interface-contract-confirming code.

What could be happening is that the samba network driver doesn't send notifications when drives for it go on line and off line. Without notifications being send, it's pretty hard when not doing cpu-intensive polling.

0

Share this post


Link to post
Share on other sites

Hi Andreas,

Completely understanding that your present time to investigate_explore into various v1.3 issues is limited (you mention for the next 5 days or so)...no problem m8 please take your time...

As I quote from your reply above:

"Fixed some small threading issues on the pidl-shortcut, other than that its pretty much all interface-contract-confirming code."

And also reviewing all threads both here and in the v1.3 [bug Report thread], hopefully this will solve the 'disappearing pidl-shortcut desklets' that some of us are experiencing after reboot (In my case-Bug Report on Pg 2), I have 'not had a explorer.exe crash' when this happens...

Will you post up updated v1.3 desklet update (when you figure it out)? As I know that you mentioned that utizing v1.1, or v1.2 pidl-shortcut desklets with v1.3 is not ideal, for the coding that has been completed for v1.3 desklets is better in the long run_for total optimized performance...

Thanks

0

Share this post


Link to post
Share on other sites

You can upload the installer to the new website. I've done a site (with Andrea's approval ) to have all desklets/skins/etc related to AveDesk located with no "linking" but real files at one site.

avedesk.philc.ca

Only people that are planning do uploading need to register. You don't need to register if you only want to download stuff.

The site is very new and I'm sure there will be future changes, but for now, I'm going back to the AveScripter devellopment.

0

Share this post


Link to post
Share on other sites
Fixed some small threading issues on the pidl-shortcut, other than that its pretty much all interface-contract-confirming code.

What could be happening is that the samba network driver doesn't send notifications when drives for it go on line and off line. Without notifications being send, it's pretty hard when not doing cpu-intensive polling.

Hm, Igot an Idea for the Next-Generation-PIDL: The possibility to use scripting to manually control the automount-feature - for example, when I'm not connected, the Network Drives' sublabel shows "0 Byte of 0 Byte free" I one could use that manually to set an automount-flag it would be great.

Additionally, if one could use the status of a different, automounting desklet, e.g. the CD-Rom drive, a disappearing eject-symbol next to the drives' desklet would be possible without much more work.

Forgot to mention: Great work you have done here!

0

Share this post


Link to post
Share on other sites

Awe and inspired! I haven't tried this but reading the posts... I'm sure this will be sweeter. Congratulations on the release Ave. You're a hero. :D

I was hoping someone can rar-ify the package. Zip and exe files doesn't work here. Thanks.

0

Share this post


Link to post
Share on other sites
AveDesk 1.3 Installer now available!

Mirroring the file untill Ave can get it on his site. ;)

I downloaded the file, but some files having been lacking in installer(ex.desklets/folder).

Does anyone supplement and re-upload it?

0

Share this post


Link to post
Share on other sites

I got a few questions how to add a folder and drive desklet to desktop? There's no shortcut for it in 1.3 like in 1.1

0

Share this post


Link to post
Share on other sites

Go to the control panel, and add a plain PIDLshortcut, and then ctrl-click on it and configure where you want it to point to.

0

Share this post


Link to post
Share on other sites

I do format my PC from time to time. Can i do the following to speedup the process of installing/setup my Avedesk?

- Close AveDesk

- ZIP entire AveDesk folder.

- After format and installing Windows.

- UNZIP the AveDesk folder exactaly as it was in the same place (C:program files)

- Click Register.bat

That should work?

0

Share this post


Link to post
Share on other sites

@musashiama: That will work perfectly, it's what I normally do. However, you do want to save your configuration folder. It will be someplace like c:documents and settingsyour usernameapplication dataavedesk. You will need to save that too....

0

Share this post


Link to post
Share on other sites
I do format my PC from time to time. Can i do the following to speedup the process of installing/setup my Avedesk?

- Close AveDesk

- ZIP entire AveDesk folder.

- After format and installing Windows.

- UNZIP the AveDesk folder exactaly as it was in the same place (C:program files)

- Click Register.bat

That should work?

I tried it and work completely.But,I want to execution program alone,so I will plan to make very simply installer.

0

Share this post


Link to post
Share on other sites
@musashiama: That will work perfectly, it's what I normally do. However, you do want to save your configuration folder. It will be someplace like c:documents and settingsyour usernameapplication dataavedesk. You will need to save that too....

Whoa... thanks, that´s important.

Thanks everybody.

0

Share this post


Link to post
Share on other sites

for the settings, if you are running with suffient write access to the AveDesk folder, you can change the following line in

settings_overrides.ini:

from

; if true, yes or 1 then themes and settings will not be stored in in

; %APPDATA%/AveDesk/, but in AveDesk's root folder.

;NoMultipleUserAwareness=true

to

; if true, yes or 1 then themes and settings will not be stored in in

; %APPDATA%/AveDesk/, but in AveDesk's root folder.

NoMultipleUserAwareness=true

.

This will let avedesk save all settings into the avedesk folder, rather than under %APPDATA%.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0