Sign in to follow this  
Followers 0

[release] Multi-Plugin 0.64 - iTunes 4.8 support & Foobar2000 passthrough!

96 posts in this topic

@ mknoffer & tetmin - I had the same issue be sure that in your foobar settings under 'Display', your 'User interface module' is set to 'iTunes Passthrough'.

That did the trick for me too .. thanks eyeball.

Great work Local.. a fantastic update to multiplugin. I know it's been said before but multiplugin truely adds to the iTunes expereince and is really appreciated by the aqua-soft community. Now all I have to do it see if I can hear any difference using foobar over iTunes default..:)

0

Share this post


Link to post
Share on other sites

I was using this everything was great but after playing some songs for a while i paused tthe song started it again and my music was playing in doubles at first I thought it was a remix until i listen to another song I do know and it sound the same. Its as if two aduio playes are playing at the same time. Dont know if anyone has experience this

0

Share this post


Link to post
Share on other sites
@ whoever wants to fix the visual bug of minimizing iTunes to system tray

Download this plug-in...

Disable the minimize option in Multi-Plugin...

And enbale the minimize to tray in this plugin

This plugin is made by someone else and I DO NOT take any credit for making it...

If you have problems right clicking the title bar... switch to the normal theme for iTunes and then try and enable it... and then you can switch back to the previous theme...

Enjoy :)

Tried it but it fux up my iTunes titlebar :/

I`m now back to 0.52 (even thought i love the non-brushed skin in 0.64 >.< )

0

Share this post


Link to post
Share on other sites

ok i got it fixed, but why cant i hear anything from my ipod in itunes? all i hear is silence

0

Share this post


Link to post
Share on other sites

ok, I'm going to rebuild the preferences dialog with tabs. That way I would have a lot more space so I could add even more options.

About the Foobar2000 passthrough - I will try to change the way of loading the Foobar plugin. maybe it will fix it.

0

Share this post


Link to post
Share on other sites

I am getting a double titlebar when I open itunes. You see the mac titlebar with the windows one on top of it. Anyone know what i'm doing wrong. I uninstalled the old mplugin and installed the new one

0

Share this post


Link to post
Share on other sites

Tom, that's a problem with ObjectBar.

It started happening here too, I've fixed it, it will be fine in the next release.

I've changed the method of making OB recognize iTunes' menu, so if it doesn't work for anyone here wait for the next release. It seems a lot better now.

btw, I've succeeded loading the Foobar plugin on the fly, without any files :)

The passthorugh should be a lot better with that. and Foobar runs fine when iTunes is closed.

0

Share this post


Link to post
Share on other sites
Got the Foobar plugin working, and it sounds great for the stuff it can play. Which is basically WAV, AAC and MP3. Unfortuantely, it's not compatible with Apple Lossless format, CDs, or (obviously) purchased iTunes music. For the AAC I have, it sounds loads better than iTunes. Unfortuantely, around 75% of my 4,201 songs are encoded in lossless, and therefore, I have to use iTunes' audio. But it's Foobar's fault for not making an Apple Lossless plugin, isn't it?

Hey what up gang? I've been familiar with the Aqua community here for a long time, but I'm new to the forums. Anyways, Capitalg you might be interested in this:Beta - Apple Lossless decoder for Foobar2000 . Using it I was able to play Apple Lossless files in iTunes with the Foobar2000 passthrough. Also for those who have the new Quicktime 7 Preview installed and are disappointing losing .ogg support with this handy plugin , it appears that .ogg files will play in iTunes using the passthough. Despite minor glitches, this plugin shows a lot of promise. Perhaps it would be possible to play .flac and .mpc files with the Foobar passthrough as well.

0

Share this post


Link to post
Share on other sites
I am getting a double titlebar when I open itunes. You see the mac titlebar with the windows one on top of it. Anyone know what i'm doing wrong. I uninstalled the old mplugin and installed the new one

I don't get this while using ob, but i do get it if i don't exclude itunes from windowblinds.

0

Share this post


Link to post
Share on other sites

thanks for releasing such a great plugin.

had long known of the foobar kernel streaming output is the best output.

great that you merge itunes with this great sound output.

:D

0

Share this post


Link to post
Share on other sites
Hey what up gang? I've been familiar with the Aqua community here for a long time, but I'm new to the forums. Anyways, Capitalg you might be interested in this:Beta - Apple Lossless decoder for Foobar2000 . Using it I was able to play Apple Lossless files in iTunes with the Foobar2000 passthrough. Also for those who have the new Quicktime 7 Preview installed and are disappointing losing .ogg support with this handy plugin , it appears that .ogg files will play in iTunes using the passthough. Despite minor glitches, this plugin shows a lot of promise. Perhaps it would be possible to play .flac and .mpc files with the Foobar passthrough as well.

Thanks for that. :D

0

Share this post


Link to post
Share on other sites
Hey what up gang? I've been familiar with the Aqua community here for a long time, but I'm new to the forums. Anyways, Capitalg you might be interested in this:Beta - Apple Lossless decoder for Foobar2000 . Using it I was able to play Apple Lossless files in iTunes with the Foobar2000 passthrough. Also for those who have the new Quicktime 7 Preview installed and are disappointing losing .ogg support with this handy plugin , it appears that .ogg files will play in iTunes using the passthough. Despite minor glitches, this plugin shows a lot of promise. Perhaps it would be possible to play .flac and .mpc files with the Foobar passthrough as well.

I don't think so. Even if we succeed adding the unsupported files to the library, It would never work perfectly. iTunes itself won't play the files, so seeking will not work, and we won't be able to retrieve current track information from iTunes.

0

Share this post


Link to post
Share on other sites
How did you resize the dialog?

I reshacked the dll and changed the size of Dialog 105.

Not the most elegant solution, but it worked for me.

0

Share this post


Link to post
Share on other sites

So I've had about every problem described here, first not seeing the entire dialog (see applelover's post above for how to fix that) and then the "no user interface" error after I had enabled the passthrough. I wasn't able to enable the itunes passthrough in Foobar because I couldn't see it, although I did see the foo_itunes.dll file in the foobar2000/components folder.

Turns out I was missing the msvcr71.dll file (search google for it, you'll find download links). It goes in the windowssystem folder.

0

Share this post


Link to post
Share on other sites

Thanks for the info, enjoing itunes with kernel streaming right now.

Edit: Ooops, sorry my mistake, kernel streaming foobar output isn't working "ERROR (foo_out_ks) : KS output error: error opening device.", only directsound and default wave out; what makes the passthrough sense less for me because that method is the only with a noticeable gain in quality. Anyway amazing work.

0

Share this post


Link to post
Share on other sites
So I've had about every problem described here, first not seeing the entire dialog (see applelover's post above for how to fix that) and then the "no user interface" error after I had enabled the passthrough. I wasn't able to enable the itunes passthrough in Foobar because I couldn't see it, although I did see the foo_itunes.dll file in the foobar2000/components folder.

Turns out I was missing the msvcr71.dll file (search google for it, you'll find download links). It goes in the windowssystem folder.

that's why I hate linking my code against DLL's.

I've based my foobar plugin on a sample one that requires that file, the next version won't require any special files.

btw, tabs are ready! that was a damn annoying work...

0

Share this post


Link to post
Share on other sites

okay, firstly just want to say that this is an awesome plugin & i love it so far...however i am having one rather annoying problem concerning the foobar passthrough thing....i initially had the same problems a lot of others were having, ie. not having the passthrough enabling option visible on the plugin preferences menu, and then having to install that missing .dll file onto my computer to get the passthrough to finally work....

...so i started playing music in itunes to test it out & could definitely notice the difference...however if i switched to a new song in the middle of another song being played, the new song that i put on got this weird and really annoying echo added onto it....and even when i stopped playing the song altogether and then hit play again, same echo problem...and also pressing pause and going to a completely different song would just give that song echoes as well...the only way it seems to fix it is to shut down itunes and restart it....however this only fixes it for the first song i play once itunes starts up again, and it will only remain echo-free if let it play through my library automatically..any manual changes in terms of choosing songs to play results in the echo effect occurring again and again...and even after uninstalling and then reinstalling both foobar and the multiplugin again, the same thing happens each time.....

....so is anyone else having this problem or am i just doing something wrong concerning the setup of the passthrough or what? i read through this entire thread quite thoroughly and i dont think i saw this mentioned anywhere before, so im hoping this is just something dumb that i'm not seeing & can be fixed easily, 'cause i was pleased with the increased output quality provided by the foobar passthrough and want to continue using itunes, so hopefully this issue can be resolved....and sry i think i just wrote a mini-book here lol, just hopin someone can help out here =/

0

Share this post


Link to post
Share on other sites

Read the instructions int the dialog ;)

You need to set the output in QuickTime to waveOut and not DirectSound.

Multi-Plugin mutes the waveOut for iTunes so you don't hear that echo.

Later I'll try to mute DirectSound too, it will be a little harder.

0

Share this post


Link to post
Share on other sites

realitybath1 - you are CORRECT

excluding Itunes in the windowblinds config fixed the problem immediately, thank you

0

Share this post


Link to post
Share on other sites

@ unbeliever...

Im sorry to see that you have a problem in that..

I have not experienced such a problem... Did you install it properly ?

Paste the .dll into a new folder by the name "Plug-Ins" without the quotes...

Or maybe you could fresh install iTunes .. then install this and after this install Mplugin?

Hope u fix the problem soon.... :)

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0