Sign in to follow this  
Followers 0

[release] Multi-Plugin 0.64 - iTunes 4.8 support & Foobar2000 passthrough!

96 posts in this topic

I'm getting the user interface message now, evey time i boot iTunes? Anyone got any ideas...

Also, iTunes refuses to quit, i close it and it just opens right up again which is a little annoying.

Cheers

0

Share this post


Link to post
Share on other sites

I'm having the same problem as tetmin's... the foobar error comes up when itunes is open, not if I try to open Foobar. I just know that it is a foobar error because the error window has a Foobar icon. And like him, when I close itunes, it just opens up again.... and I can't disable the scripting interface thing.

Am I the only one who hates it when some jackass says "read the first message of the topic"?

0

Share this post


Link to post
Share on other sites

You said, "I have a Foobar Error that says no user interface found." I also got this error, except I received it when I tried to open Foobar. So, it wasn't an outrageous assumption to think you might have the same error. Sorry for being a jackass..

0

Share this post


Link to post
Share on other sites

This is the exact message we're getting:

"WARNING (CORE) : User interface: "Default User Interface" not found, trying defaults.

WARNING (CORE) : Default user interface not found, trying any available.

INFO (CORE) : startup time: 360 ms"

Immediatley after activating the plugin and every time iTunes is loaded. I've uninstalled everything, and reinstalled again but still getting it.

Thanks

0

Share this post


Link to post
Share on other sites

igo, buddyd16: I'll see what's wrong with the media keys. many users reported that.

starforge: try deleting files from the Extended folder to see which file makes the problem. especially look at the QT files, they tend to crash iTunes more, as they are far more sensitive.

when you detect the file(s), please post their names so I could see what could be the reason.

btw, have you let the installer delete your skins? an old developer template could crash iTunes too.

realitybath1: what popup notification?

Unbeliever, zondajag: You can turn off the minimize animation in Windows to fix it. Multi-Plugin makes iTunes minimize itself before every attempt to hide the main window, thus you see a double minimize animation. that's what makes iTunes use just about 5MB of memory when minimized to tray. maybe I'll make a poll about removing this feature, too many users complain about it...

WishIwasMissing, jggame: can you hear sound from iTunes with the feature enabled? can you run Foobar with it enabled? and do you see foo_iTunes.dll in the components folder in Foobar's folder? that DLL is a UI plugin for Foobar so iTunes could interact with it. try enabling it manually if Multi-Plugin doesn't do it.

XalCore: from the thread you have posted I understand your computer has some problems with COM. maybe uninstalling and reinstalling iTunes will help.

thekingart, applelover: it's in the preferences dialog, like all the other options. could you post a screenshot of you preferences dialog? (in the Multi-Plugin tab, of course)

Nico, scheming: press Alt+E. you shouldn't have pressed Alt+Down, but Alt and then Down. I'll replace it in the documentation next time, I guess the "Alt and then Down" thing is confusing.

FatAxl: what's exactly the problem? do you see it in the preferences dialog? read my reply to WishIwasMissing and jggame.

dkordik: that thing requires a playlist in Foobar, doesn't it? doing it will require getting the next playing track from iTunes and making a playlist every time a track is played. It would be a little slower, and even if I could sort it, it would lead to synchronization problems - the time in iTunes will be a couple of seconds off - and it won't feel like "native iTunes" at all.

capitalq: well it's not the only thing missing in your dialog. all the coordinates of the dialog are off. do you have large fonts enabled? try turning that off or switching your visual style. Also it appears that you don't have the Lucida Grande font installed. Multi-Plugin should install it for you, try reinstalling it or downloading this font somewhere.

mknoffer, tetmin:do you have the foo_iTunes.dll file in the components folder in your Foobar2000 folder?

0

Share this post


Link to post
Share on other sites

@capitalq--If you don't have large fonts enabled, it's probably your DPI. Change from big, to normal sized.

-NC

0

Share this post


Link to post
Share on other sites

You have just made my wish come true

I so badly wanted Itunes to sound like my foobar setup

:D

thanks mate

0

Share this post


Link to post
Share on other sites
mknoffer, tetmin:do you have the foo_iTunes.dll file in the components folder in your Foobar2000 folder?

I've got the .dll in that file...

Thanks

0

Share this post


Link to post
Share on other sites
WishIwasMissing, jggame: can you hear sound from iTunes with the feature enabled? can you run Foobar with it enabled? and do you see foo_iTunes.dll in the components folder in Foobar's folder? that DLL is a UI plugin for Foobar so iTunes could interact with it. try enabling it manually if Multi-Plugin doesn't do it.
The installer didnĀ“t provided me a check dialog or a reference to foobar and there is not foo_iTunes.dll plugin in the components foobar folder. (non english windowsxp sp2)
0

Share this post


Link to post
Share on other sites

@ mknoffer & tetmin - I had the same issue be sure that in your foobar settings under 'Display', your 'User interface module' is set to 'iTunes Passthrough'.

0

Share this post


Link to post
Share on other sites

Is it just me or has the foobar passthrough completely disabled the playback of Radio Streams on Itunes. Cannot playback the streams any longer, anyone else notice this and is there a workaround in the foobar settings.

0

Share this post


Link to post
Share on other sites

I finally got the foobar passthrough to work... I just couldnt see it in my preferences so i had to tab down to it... unfortunately i dont know whether the last 3 options besides foobar are enabled :(... maybe a scrollbar in the next release or something to fix this problem?

also i get the problem where itunes gives the error dialog

WARNING (CORE) : User interface: "Default User Interface" not found, trying defaults.

WARNING (CORE) : Default user interface not found, trying any available.

is this normal or is something messed up?... basically asking is that foobar trying to find its gui? or is that itunes having problems?

other than that the passthrough sounds great... good work looking forward to your next release

0

Share this post


Link to post
Share on other sites

eyeball1978, thanks for the reply but i don't have that option in my display settings which is a bit wierd, the only option in the drop down list is "default user interface", even though the foo_itunes.dll is in my components folder.

0

Share this post


Link to post
Share on other sites

My DPI is normal size, fonts are set to normal, and I've always had Lucida Grande installed.

0

Share this post


Link to post
Share on other sites
thekingart, applelover: it's in the preferences dialog, like all the other options. could you post a screenshot of you preferences dialog? (in the Multi-Plugin tab, of course)

OK, see attachment.

I fixed it by resizing the dialog so that i could see the options that were hidden

post-1003-1119573079_thumb.jpg

0

Share this post


Link to post
Share on other sites
Is it just me or has the foobar passthrough completely disabled the playback of Radio Streams on Itunes. Cannot playback the streams any longer, anyone else notice this and is there a workaround in the foobar settings.

Anyone with any knowledge of this, before it gets lost in the thread. I'm not getting anywhere attempting to rectify it, short of I guess removing the plugin?

0

Share this post


Link to post
Share on other sites

can someone post the foo_itunes.dll? for some reason i installed and still didnt get it

0

Share this post


Link to post
Share on other sites

@ whoever wants to fix the visual bug of minimizing iTunes to system tray

Download this plug-in...

Disable the minimize option in Multi-Plugin...

And enbale the minimize to tray in this plugin

This plugin is made by someone else and I DO NOT take any credit for making it...

If you have problems right clicking the title bar... switch to the normal theme for iTunes and then try and enable it... and then you can switch back to the previous theme...

Enjoy :)

iTunes_SideKick_v1_3_0.zip

0

Share this post


Link to post
Share on other sites

For those like me who can't see the Foobar checkbox, you can tab to it, its the third and you can tell as a warning box pops up stating that it is an expiremental feature. good luck :)

EDIT: I'm pretty sure that the foo_iTunes.dll file gets created once you enable the option as it was not there until i enable the passthrough.

0

Share this post


Link to post
Share on other sites

I find it funny that even FooBar2000's developers have something to say about "sound quality":

Does foobar2000 sound better than other players?

No. Most of "sound quality differences" people "hear" are placebo effect (at least with real music), as actual differences in produced sound data are below their noise floor (1 or 2 last bits in 16bit samples). Foobar2000 has sound processing features such as software resampling or 24bit output on new high-end soundcards, but most of other mainstream players are capable of doing the same by now.

0

Share this post


Link to post
Share on other sites
OK, see attachment.

I fixed it by resizing the dialog so that i could see the options that were hidden

How did you resize the dialog?

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0